summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/farsight2/farsight2-0.0.17.ebuild')
-rw-r--r--net-libs/farsight2/farsight2-0.0.17.ebuild62
1 files changed, 0 insertions, 62 deletions
diff --git a/net-libs/farsight2/farsight2-0.0.17.ebuild b/net-libs/farsight2/farsight2-0.0.17.ebuild
deleted file mode 100644
index c4dc22503657..000000000000
--- a/net-libs/farsight2/farsight2-0.0.17.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/farsight2/farsight2-0.0.17.ebuild,v 1.11 2011/07/08 10:01:30 ssuominen Exp $
-
-EAPI="2"
-
-DESCRIPTION="Farsight2 is an audio/video conferencing framework specifically designed for Instant Messengers."
-HOMEPAGE="http://farsight.freedesktop.org/"
-SRC_URI="http://farsight.freedesktop.org/releases/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-KEYWORDS="alpha amd64 ~arm hppa ia64 ~ppc ~ppc64 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="python test msn upnp"
-SLOT="0"
-
-# tests are sometimes broken :-(
-RESTRICT=test
-
-COMMONDEPEND=">=media-libs/gstreamer-0.10.23
- >=media-libs/gst-plugins-base-0.10.23
- >=dev-libs/glib-2.16
- >=net-libs/libnice-0.0.9[gstreamer]
- <net-libs/libnice-0.1.0
- python? (
- || ( >=dev-python/pygobject-2.16 >=dev-python/pygtk-2.12 )
- >=dev-python/pygobject-2.12
- >=dev-python/gst-python-0.10.10 )
- upnp? ( net-libs/gupnp-igd )"
-
-RDEPEND="${COMMONDEPEND}
- >=media-libs/gst-plugins-good-0.10.11
- >=media-libs/gst-plugins-bad-0.10.13
- || ( >=media-libs/gst-plugins-good-0.10.16
- <media-libs/gst-plugins-bad-0.10.14 )
- msn? ( >=media-plugins/gst-plugins-mimic-0.10.14 )"
-
-DEPEND="${COMMONDEPEND}
- test? ( media-plugins/gst-plugins-vorbis
- media-plugins/gst-plugins-speex )
- dev-util/pkgconfig"
-
-src_configure() {
- plugins="fsrtpconference,funnel,rtcpfilter,videoanyrate"
- use msn && plugins="${plugins},fsmsnconference"
- econf $(use_enable python) \
- $(use_enable upnp gupnp) \
- --with-plugins=${plugins}
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die "emake install failed"
- dodoc AUTHORS README ChangeLog
-}
-
-src_test()
-{
- use msn || { einfo "Tests disabled without msn use flag"; return ;}
- if ! emake -j1 check; then
- has test $FEATURES && die "Make check failed. See above for details."
- has test $FEATURES || eerror "Make check failed. See above for details."
- fi
-}