summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/tcpdump/tcpdump-3.7.1.ebuild')
-rw-r--r--net-analyzer/tcpdump/tcpdump-3.7.1.ebuild43
1 files changed, 18 insertions, 25 deletions
diff --git a/net-analyzer/tcpdump/tcpdump-3.7.1.ebuild b/net-analyzer/tcpdump/tcpdump-3.7.1.ebuild
index 00b457d102be..22dca9998f99 100644
--- a/net-analyzer/tcpdump/tcpdump-3.7.1.ebuild
+++ b/net-analyzer/tcpdump/tcpdump-3.7.1.ebuild
@@ -1,42 +1,35 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpdump/tcpdump-3.7.1.ebuild,v 1.3 2002/07/18 15:01:43 nitro Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpdump/tcpdump-3.7.1.ebuild,v 1.4 2002/07/18 23:22:51 seemant Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="A Tool for network monitoring and data acquisition"
-SRC_URI="http://www.tcpdump.org/release/${A}
- http://www.jp.tcpdump.org/release/${A}"
+SRC_URI="http://www.tcpdump.org/release/${P}.tar.gz
+ http://www.jp.tcpdump.org/release/${P}.tar.gz"
HOMEPAGE="http://www.tcpdump.org/"
LICENSE="BSD"
SLOT="0"
KEYWORDS="x86"
-DEPEND="virtual/glibc
- ssl? ( >=dev-libs/openssl-0.6.9 )
- >=net-libs/libpcap-0.6.1"
-
-RDEPEND="virtual/glibc
+DEPEND=">=net-libs/libpcap-0.6.1
ssl? ( >=dev-libs/openssl-0.6.9 )"
+
src_compile() {
- local myconf
- if [ -z "`use ssl`" ] ; then
- myconf="--without-crypto"
- fi
- try ./configure --host=${CHOST} --prefix=/usr --enable-ipv6 $myconf
-#--disable-ipv6
- try make CCOPT="$CFLAGS"
-}
+ local myconf
-src_install() {
- into /usr
- dobin tcpdump
- doman tcpdump.1
- dodoc *.awk
- dodoc README FILES VERSION CHANGES
+ use ssl || myconf="--without-crypto"
+ econf \
+ --enable-ipv6 \
+ ${myconf} || die
+ make CCOPT="$CFLAGS" || die
}
-
-
+src_install() {
+ into /usr
+ dobin tcpdump
+ doman tcpdump.1
+ dodoc *.awk
+ dodoc README FILES VERSION CHANGES
+}