summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/nvclock/nvclock-0.8_beta4.ebuild')
-rw-r--r--media-video/nvclock/nvclock-0.8_beta4.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/media-video/nvclock/nvclock-0.8_beta4.ebuild b/media-video/nvclock/nvclock-0.8_beta4.ebuild
deleted file mode 100644
index 245c7efc7af6..000000000000
--- a/media-video/nvclock/nvclock-0.8_beta4.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/nvclock/nvclock-0.8_beta4.ebuild,v 1.1 2009/03/13 21:43:37 bangert Exp $
-
-inherit eutils autotools
-
-MY_P="${PN}${PV/_beta/b}"
-S=${WORKDIR}/${MY_P}
-DESCRIPTION="NVIDIA Overclocking Utility"
-HOMEPAGE="http://www.linuxhardware.org/nvclock/"
-SRC_URI="http://www.linuxhardware.org/nvclock/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE="gtk qt3"
-
-RDEPEND="virtual/libc
- gtk? ( =x11-libs/gtk+-2* )
- qt3? ( =x11-libs/qt-3* )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Patch to fix broken autoconf macro "--with-qt-libs" needed below
- # Submitted upstream, hopefully fixed in a later version
- use qt3 && epatch "${FILESDIR}"/nvclock_acinclude_qtlibs.patch
-
- eautoreconf
-}
-
-src_compile() {
- # Needed to ensure it compiles against Qt3 rather than Qt4
- export QTDIR=/usr/qt/3
- export MOC=${QTDIR}/bin/moc
-
- local myconf
-
- # Qt3 package doesn't install symlinks from ${QTDIR}/lib64 to ${QTDIR}/lib
- use amd64 && myconf="${myconf} --with-qt-libs=${QTDIR}/lib64"
-
- ./configure $(use_enable qt3 qt) $(use_enable gtk) ${myconf} || die
-
- make || die
-}
-
-src_install() {
- dodir /usr/bin
- einstall || die
- dodoc AUTHORS README
-
- newinitd "${FILESDIR}"/nvclock_initd nvclock
- newconfd "${FILESDIR}"/nvclock_confd nvclock
-}
-
-pkg_postinst() {
- elog "To enable card overclocking at startup, edit your /etc/conf.d/nvclock"
- elog "accordingly and then run: rc-update add nvclock default"
-}