summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/mp3splt/mp3splt-2.1.ebuild')
-rw-r--r--media-sound/mp3splt/mp3splt-2.1.ebuild25
1 files changed, 10 insertions, 15 deletions
diff --git a/media-sound/mp3splt/mp3splt-2.1.ebuild b/media-sound/mp3splt/mp3splt-2.1.ebuild
index 03de25749223..94d3e5cf3973 100644
--- a/media-sound/mp3splt/mp3splt-2.1.ebuild
+++ b/media-sound/mp3splt/mp3splt-2.1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3splt/mp3splt-2.1.ebuild,v 1.11 2007/01/11 16:44:11 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3splt/mp3splt-2.1.ebuild,v 1.12 2009/06/01 15:03:38 ssuominen Exp $
+EAPI=2
inherit eutils
DESCRIPTION="A command line utility to split mp3 and vorbis files"
@@ -13,26 +14,20 @@ SLOT="0"
KEYWORDS="alpha amd64 ~hppa -mips ppc ~ppc64 sparc x86"
IUSE="vorbis"
-DEPEND="vorbis? ( media-libs/libvorbis )
+RDEPEND="vorbis? ( media-libs/libvorbis )
media-libs/libmad"
+DEPEND="${RDEPEND}"
-src_unpack() {
- unpack ${A}
-
+src_prepare() {
epatch "${FILESDIR}"/${P}-gcc41.patch
}
-src_compile() {
- local myconf
-
- # --enable-ogg doesn't enable ogg...
- use vorbis || myconf="--disable-ogg"
- econf ${myconf} || die "econf failed"
-
- emake || die "build failed"
+src_configure() {
+ use vorbis || local myconf="--disable-ogg"
+ econf ${myconf}
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS ChangeLog NEWS README
}