summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/freebirth/freebirth-0.3.2.ebuild')
-rw-r--r--media-sound/freebirth/freebirth-0.3.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-sound/freebirth/freebirth-0.3.2.ebuild b/media-sound/freebirth/freebirth-0.3.2.ebuild
new file mode 100644
index 000000000000..ff8f4e6c7d16
--- /dev/null
+++ b/media-sound/freebirth/freebirth-0.3.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/freebirth/freebirth-0.3.2.ebuild,v 1.1 2003/06/21 00:41:11 jje Exp $
+
+DESCRIPTION="Free software bass synthesizer step sequencer"
+HOMEPAGE="http://www.bitmechanic.com/projects/freebirth/"
+SRC_URI="http://www.bitmechanic.com/projects/freebirth/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="=x11-libs/gtk+-1.2*
+ =dev-libs/glib-1.2*"
+
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.patch
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS} $(gtk-config --cflags)" || die
+}
+
+src_install() {
+ dobin freebirth
+
+ insinto /usr/lib/${PN}/raw
+ doins raw/*.raw
+
+ dodoc CHANGES INSTALL NEXT_VERSION README
+}
+