summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/mythdvd/mythdvd-0.20_p11329.ebuild')
-rw-r--r--media-plugins/mythdvd/mythdvd-0.20_p11329.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-plugins/mythdvd/mythdvd-0.20_p11329.ebuild b/media-plugins/mythdvd/mythdvd-0.20_p11329.ebuild
new file mode 100644
index 000000000000..bbc1725cd1f8
--- /dev/null
+++ b/media-plugins/mythdvd/mythdvd-0.20_p11329.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythdvd/mythdvd-0.20_p11329.ebuild,v 1.1 2006/09/29 14:30:37 cardoe Exp $
+
+inherit mythtv-plugins
+
+DESCRIPTION="DVD player module for MythTV."
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="transcode"
+
+RDEPEND="=media-plugins/mythvideo-${MY_PV}*
+ transcode? ( media-video/transcode
+ media-libs/libdvdread )
+ || ( media-video/mplayer media-video/xine-ui media-video/ogle )"
+
+MTVCONF="--enable-vcd $(use_enable transcode)"
+
+src_install() {
+ mythtv-plugins_src_install
+
+ newinitd "${FILESDIR}"/mtd.init mtd
+}
+
+pkg_postinst() {
+ echo
+ einfo "To have Myth Transcode Daemon (mtd) start on boot do the following"
+ einfo "rc-update add mtd default"
+ einfo "Make sure you run 'mtd -n' to setup mtd first"
+ echo
+}