summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libsdl2/libsdl2-2.0.2-r1.ebuild')
-rw-r--r--media-libs/libsdl2/libsdl2-2.0.2-r1.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/media-libs/libsdl2/libsdl2-2.0.2-r1.ebuild b/media-libs/libsdl2/libsdl2-2.0.2-r1.ebuild
index 4fe2007d70c3..90eaae78f094 100644
--- a/media-libs/libsdl2/libsdl2-2.0.2-r1.ebuild
+++ b/media-libs/libsdl2/libsdl2-2.0.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl2/libsdl2-2.0.2-r1.ebuild,v 1.3 2014/04/21 07:56:51 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl2/libsdl2-2.0.2-r1.ebuild,v 1.4 2014/05/10 16:46:06 hasufell Exp $
# TODO: convert FusionSound #484250
@@ -16,7 +16,7 @@ LICENSE="ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="3dnow alsa altivec +audio custom-cflags dbus fusionsound gles haptic +joystick mmx nas opengl oss pulseaudio sse sse2 static-libs +threads tslib udev +video X xinerama xscreensaver"
+IUSE="3dnow alsa altivec +audio custom-cflags dbus fusionsound gles haptic +joystick mmx nas opengl oss pulseaudio sse sse2 static-libs +threads tslib udev +video wayland X xinerama xscreensaver"
REQUIRED_USE="
alsa? ( audio )
fusionsound? ( audio )
@@ -40,6 +40,11 @@ RDEPEND="
pulseaudio? ( media-sound/pulseaudio[${MULTILIB_USEDEP}] )
tslib? ( x11-libs/tslib[${MULTILIB_USEDEP}] )
udev? ( virtual/udev[${MULTILIB_USEDEP}] )
+ wayland? (
+ dev-libs/wayland[${MULTILIB_USEDEP}]
+ media-libs/mesa[${MULTILIB_USEDEP},wayland]
+ x11-libs/libxkbcommon[${MULTILIB_USEDEP}]
+ )
X? (
x11-libs/libX11[${MULTILIB_USEDEP}]
x11-libs/libXcursor[${MULTILIB_USEDEP}]
@@ -107,6 +112,8 @@ multilib_src_configure() {
$(use_enable audio dummyaudio) \
$(use_enable X video-x11) \
--disable-x11-shared \
+ $(use_enable wayland video-wayland) \
+ --disable-wayland-shared \
$(use_enable X video-x11-xcursor) \
$(use_enable xinerama video-x11-xinerama) \
$(use_enable X video-x11-xinput) \