summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/jasper/jasper-1.900.1.ebuild')
-rw-r--r--media-libs/jasper/jasper-1.900.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-libs/jasper/jasper-1.900.1.ebuild b/media-libs/jasper/jasper-1.900.1.ebuild
new file mode 100644
index 000000000000..f1d7f232f622
--- /dev/null
+++ b/media-libs/jasper/jasper-1.900.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/jasper/jasper-1.900.1.ebuild,v 1.1 2007/01/23 16:21:32 phosphan Exp $
+
+inherit libtool
+
+DESCRIPTION="software-based implementation of the codec specified in the JPEG-2000 Part-1 standard"
+HOMEPAGE="http://www.ece.uvic.ca/~mdadams/jasper/"
+SRC_URI="http://www.ece.uvic.ca/~mdadams/jasper/software/jasper-${PV}.zip"
+
+LICENSE="JasPer"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh
+~sparc ~x86 ~x86-fbsd"
+IUSE="opengl jpeg"
+
+RDEPEND="jpeg? ( media-libs/jpeg )
+ opengl? ( virtual/opengl virtual/glut )"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ elibtoolize
+}
+
+src_compile() {
+ econf \
+ $(use_enable jpeg libjpeg) \
+ $(use_enable opengl) \
+ --enable-shared \
+ || die
+ emake || die "If you got undefined references to OpenGL related libraries,please try 'eselect opengl set xorg-x11' before emerging. See bug #133609."
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc NEWS README doc/*
+}