summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/f-spot/files/f-spot-0.6.0.0-sandbox-violation.patch')
-rw-r--r--media-gfx/f-spot/files/f-spot-0.6.0.0-sandbox-violation.patch67
1 files changed, 67 insertions, 0 deletions
diff --git a/media-gfx/f-spot/files/f-spot-0.6.0.0-sandbox-violation.patch b/media-gfx/f-spot/files/f-spot-0.6.0.0-sandbox-violation.patch
new file mode 100644
index 000000000000..73469dca89de
--- /dev/null
+++ b/media-gfx/f-spot/files/f-spot-0.6.0.0-sandbox-violation.patch
@@ -0,0 +1,67 @@
+From 82322bb8461eca5a06e2ec05a5705bc52fada244 Mon Sep 17 00:00:00 2001
+From: Jim Ramsay <i.am@jimramsay.com>
+Date: Mon, 10 Aug 2009 14:03:38 -0400
+Subject: [PATCH 19/19] Make install-data-hook respect DESTDIR
+
+---
+ extensions/Exporters/FlickrExport/Makefile.am | 2 +-
+ extensions/Exporters/PicasaWebExport/Makefile.am | 2 +-
+ extensions/Exporters/SmugMugExport/Makefile.am | 2 +-
+ extensions/Exporters/TabbloExport/Makefile.am | 2 +-
+ 4 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/extensions/Exporters/FlickrExport/Makefile.am b/extensions/Exporters/FlickrExport/Makefile.am
+index 2535352..46c70e6 100644
+--- a/extensions/Exporters/FlickrExport/Makefile.am
++++ b/extensions/Exporters/FlickrExport/Makefile.am
+@@ -45,7 +45,7 @@ $(PLUGIN_ASSEMBLY): $(PLUGIN_SOURCES) $(PLUGIN_MANIFEST)
+ plugindir = $(pkglibdir)/extensions
+
+ install-data-hook:
+- rm -f $(plugindir)/$(PLUGIN_NAME).addin.xml
++ -rm -f "$(DESTDIR)$(plugindir)/$(PLUGIN_NAME).addin.xml"
+
+ plugin_DATA = \
+ $(PLUGIN_ASSEMBLY)
+diff --git a/extensions/Exporters/PicasaWebExport/Makefile.am b/extensions/Exporters/PicasaWebExport/Makefile.am
+index 4b39ee2..25d0322 100644
+--- a/extensions/Exporters/PicasaWebExport/Makefile.am
++++ b/extensions/Exporters/PicasaWebExport/Makefile.am
+@@ -46,7 +46,7 @@ $(PLUGIN_ASSEMBLY): $(PLUGIN_SOURCES) $(PLUGIN_MANIFEST)
+ plugindir = $(pkglibdir)/extensions
+
+ install-data-hook:
+- rm -f $(plugindir)/$(PLUGIN_NAME).addin.xml
++ -rm -f "$(DESTDIR)$(plugindir)/$(PLUGIN_NAME).addin.xml"
+
+ plugin_DATA = \
+ $(PLUGIN_ASSEMBLY)
+diff --git a/extensions/Exporters/SmugMugExport/Makefile.am b/extensions/Exporters/SmugMugExport/Makefile.am
+index 5e2d8b6..bed9b68 100644
+--- a/extensions/Exporters/SmugMugExport/Makefile.am
++++ b/extensions/Exporters/SmugMugExport/Makefile.am
+@@ -46,7 +46,7 @@ $(PLUGIN_ASSEMBLY): $(PLUGIN_SOURCES) $(PLUGIN_MANIFEST)
+ plugindir = $(pkglibdir)/extensions
+
+ install-data-hook:
+- rm -f $(plugindir)/$(PLUGIN_NAME).addin.xml
++ -rm -f "$(DESTDIR)$(plugindir)/$(PLUGIN_NAME).addin.xml"
+
+ plugin_DATA = \
+ $(PLUGIN_ASSEMBLY)
+diff --git a/extensions/Exporters/TabbloExport/Makefile.am b/extensions/Exporters/TabbloExport/Makefile.am
+index b4ffd33..233ba73 100644
+--- a/extensions/Exporters/TabbloExport/Makefile.am
++++ b/extensions/Exporters/TabbloExport/Makefile.am
+@@ -55,7 +55,7 @@ $(PLUGIN_ASSEMBLY): $(PLUGIN_SOURCES) $(PLUGIN_MANIFEST)
+ plugindir = $(pkglibdir)/extensions
+
+ install-data-hook:
+- rm -f $(plugindir)/$(PLUGIN_NAME).addin.xml
++ -rm -f "$(DESTDIR)$(plugindir)/$(PLUGIN_NAME).addin.xml"
+
+ plugin_DATA = \
+ $(PLUGIN_ASSEMBLY)
+--
+1.6.3.3
+