summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-misc/kgtk/kgtk-0.10.1.ebuild')
-rw-r--r--kde-misc/kgtk/kgtk-0.10.1.ebuild21
1 files changed, 12 insertions, 9 deletions
diff --git a/kde-misc/kgtk/kgtk-0.10.1.ebuild b/kde-misc/kgtk/kgtk-0.10.1.ebuild
index 1b5519830bde..eaa3164f6c53 100644
--- a/kde-misc/kgtk/kgtk-0.10.1.ebuild
+++ b/kde-misc/kgtk/kgtk-0.10.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/kgtk/kgtk-0.10.1.ebuild,v 1.6 2010/08/09 13:05:10 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kgtk/kgtk-0.10.1.ebuild,v 1.7 2011/01/31 05:06:13 tampakrap Exp $
-EAPI=2
+EAPI=3
KDE_LINGUAS="cs de en_GB es fr pt_BR ru zh_CN"
KDE_LINGUAS_DIR="kdialogd4/po"
inherit kde4-base
@@ -12,23 +12,26 @@ HOMEPAGE="http://www.kde-apps.org/content/show.php?content=36077"
SRC_URI="http://home.freeuk.com/cpdrummond/KGtk-${PV}.tar.bz2"
LICENSE="GPL-2"
-SLOT="0"
+SLOT="4"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="debug"
-DEPEND="x11-libs/gtk+:2
+DEPEND="
+ x11-libs/gtk+:2
x11-libs/qt-gui:4
- >=kde-base/kdebase-startkde-${KDE_MINIMAL}"
+ $(add_kdebase_dep kdebase-startkde)
+"
PATCHES=( "${FILESDIR}/${P}-glibc-2.10.patch" )
S=${WORKDIR}/KGtk-${PV}
-DOCS="AUTHORS ChangeLog README TODO"
+DOCS=( AUTHORS ChangeLog README TODO )
src_configure() {
- mycmakeargs="${mycmakeargs}
- -DKGTK_KDE4=true -DKGTK_QT4=true -DKGTK_GTK2=true"
+ mycmakeargs+=(
+ -DKGTK_KDE4=true -DKGTK_QT4=true -DKGTK_GTK2=true
+ )
kde4-base_src_configure
}