summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/noatun-plugins/noatun-plugins-3.5.0.ebuild')
-rw-r--r--kde-base/noatun-plugins/noatun-plugins-3.5.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/kde-base/noatun-plugins/noatun-plugins-3.5.0.ebuild b/kde-base/noatun-plugins/noatun-plugins-3.5.0.ebuild
new file mode 100644
index 000000000000..aa2d9af286c1
--- /dev/null
+++ b/kde-base/noatun-plugins/noatun-plugins-3.5.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/noatun-plugins/noatun-plugins-3.5.0.ebuild,v 1.1 2005/11/22 22:14:16 danarmak Exp $
+KMNAME=kdeaddons
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta
+
+DESCRIPTION="Various plugins for noatun"
+KEYWORDS="~amd64 ~x86"
+IUSE="arts sdl berkdb"
+DEPEND="$(deprange-dual $PV $MAXKDEVER kde-base/noatun)
+ arts? ( $(deprange $PV $MAXKDEVER kde-base/arts) )
+ sdl? ( >=media-libs/libsdl-1.2 )
+ berkdb? ( || ( =sys-libs/db-4.3*
+ =sys-libs/db-4.2* ) )"
+
+src_compile() {
+ local myconf="$(use_with sdl)"
+
+ if use berkdb; then
+ if has_version "=sys-libs/db-4.3*"; then
+ myconf="${myconf} --with-berkeley-db --with-db-lib=db_cxx-4.3
+ --with-extra-includes=/usr/include/db4.3"
+ elif has_version "=sys-libs/db-4.2*"; then
+ myconf="${myconf} --with-berkeley-db --with-db-lib=db_cxx-4.2
+ --with-extra-includes=/usr/include/db4.2"
+ fi
+ else
+ myconf="${myconf} --without-berkeley-db"
+ fi
+
+ kde-meta_src_compile
+}