summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/ktux')
-rw-r--r--kde-base/ktux/ChangeLog7
-rw-r--r--kde-base/ktux/ktux-4.6.1.ebuild26
2 files changed, 32 insertions, 1 deletions
diff --git a/kde-base/ktux/ChangeLog b/kde-base/ktux/ChangeLog
index 966af00a4bfb..c5a5a2e5379e 100644
--- a/kde-base/ktux/ChangeLog
+++ b/kde-base/ktux/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ktux
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ktux/ChangeLog,v 1.160 2011/01/26 20:28:47 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ktux/ChangeLog,v 1.161 2011/03/04 18:00:07 alexxy Exp $
+
+*ktux-4.6.1 (04 Mar 2011)
+
+ 04 Mar 2011; Alexey Shvetsov <alexxy@gentoo.org> +ktux-4.6.1.ebuild:
+ Version bump KDE SC 4.6.1
*ktux-4.6.0 (26 Jan 2011)
diff --git a/kde-base/ktux/ktux-4.6.1.ebuild b/kde-base/ktux/ktux-4.6.1.ebuild
new file mode 100644
index 000000000000..7b8e76aa794d
--- /dev/null
+++ b/kde-base/ktux/ktux-4.6.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ktux/ktux-4.6.1.ebuild,v 1.1 2011/03/04 18:00:07 alexxy Exp $
+
+EAPI=3
+
+KMNAME="kdetoys"
+inherit kde4-meta
+
+DESCRIPTION="KDE: screensaver featuring the Space-Faring Tux"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+# libkworkspace - only as a stub to provide KDE4Workspace config
+DEPEND="
+ $(add_kdebase_dep kscreensaver)
+ $(add_kdebase_dep libkworkspace)
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e's/${KDE4WORKSPACE_KSCREENSAVER_LIBRARY}/kscreensaver/' \
+ "${PN}"/src/CMakeLists.txt || die "Failed to patch CMakeLists.txt"
+
+ kde4-meta_src_prepare
+}