summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kdenetwork/kdenetwork-3.5.6-r1.ebuild')
-rw-r--r--kde-base/kdenetwork/kdenetwork-3.5.6-r1.ebuild20
1 files changed, 12 insertions, 8 deletions
diff --git a/kde-base/kdenetwork/kdenetwork-3.5.6-r1.ebuild b/kde-base/kdenetwork/kdenetwork-3.5.6-r1.ebuild
index 5b05cc8f70f3..cf9e21ac103e 100644
--- a/kde-base/kdenetwork/kdenetwork-3.5.6-r1.ebuild
+++ b/kde-base/kdenetwork/kdenetwork-3.5.6-r1.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdenetwork/kdenetwork-3.5.6-r1.ebuild,v 1.3 2007/05/05 05:16:26 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdenetwork/kdenetwork-3.5.6-r1.ebuild,v 1.4 2007/05/07 16:07:55 philantrop Exp $
inherit kde-dist eutils flag-o-matic
DESCRIPTION="KDE network applications: Kopete, KPPP, KGet,..."
-KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="crypt jingle kdehiddenvisibility rdesktop sametime slp ssl wifi"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="jingle kdehiddenvisibility rdesktop sametime slp ssl wifi"
SRC_URI="${SRC_URI}
mirror://gentoo/kdenetwork-3.5-patchset-01.tar.bz2"
@@ -36,8 +36,7 @@ RDEPEND="${BOTH_DEPEND}
dev-lang/perl
ssl? ( dev-perl/IO-Socket-SSL
app-crypt/qca-tls )
- net-dialup/ppp
- crypt? ( app-crypt/gnupg )"
+ net-dialup/ppp"
DEPEND="${BOTH_DEPEND}
kernel_linux? ( virtual/os-headers )
@@ -46,10 +45,9 @@ DEPEND="${BOTH_DEPEND}
kernel_linux? ( x11-libs/libXv )
x11-proto/scrnsaverproto"
-PDEPEND="crypt? ( net-im/kopete-otr )"
-
PATCHES="${FILESDIR}/kopete-3.5.5-icqfix.patch
- ${FILESDIR}/kdenetwork-3.5.5-linux-headers-2.6.18.patch"
+ ${FILESDIR}/kdenetwork-3.5.5-linux-headers-2.6.18.patch
+ ${FILESDIR}/kopete-3.5.6-cryptobug.patch"
pkg_setup() {
if use kernel_linux && ! built_with_use =x11-libs/qt-3* opengl; then
@@ -88,3 +86,9 @@ src_install() {
newconfd "${WORKDIR}/patches/lisa.conf" lisa
newconfd "${WORKDIR}/patches/reslisa.conf" reslisa
}
+
+pkg_postinst() {
+ kde_pkg_postinst
+
+ elog "If you would like to use Off-The-Record encryption with Kopete, emerge net-im/kopete-otr."
+}