summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kdegraphics/kdegraphics-3.5.5-r2.ebuild')
-rw-r--r--kde-base/kdegraphics/kdegraphics-3.5.5-r2.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/kde-base/kdegraphics/kdegraphics-3.5.5-r2.ebuild b/kde-base/kdegraphics/kdegraphics-3.5.5-r2.ebuild
new file mode 100644
index 000000000000..00d6ef3f7ef4
--- /dev/null
+++ b/kde-base/kdegraphics/kdegraphics-3.5.5-r2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics/kdegraphics-3.5.5-r2.ebuild,v 1.1 2007/02/07 18:26:13 flameeyes Exp $
+
+inherit kde-dist eutils
+
+DESCRIPTION="KDE graphics-related apps"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="gphoto2 imlib openexr opengl pdf povray scanner tetex"
+
+DEPEND="~kde-base/kdebase-${PV}
+ >=media-libs/freetype-2
+ media-libs/fontconfig
+ gphoto2? ( media-libs/libgphoto2 )
+ scanner? ( media-gfx/sane-backends )
+ media-libs/libart_lgpl
+ media-libs/lcms
+ dev-libs/fribidi
+ imlib? ( media-libs/imlib )
+ virtual/ghostscript
+ media-libs/tiff
+ openexr? ( >=media-libs/openexr-1.2 )
+ povray? ( media-gfx/povray
+ virtual/opengl )
+ pdf? ( >=app-text/poppler-0.5.1
+ >=app-text/poppler-bindings-0.5.1 )"
+
+RDEPEND="${DEPEND}
+ tetex? (
+ || ( >=app-text/tetex-2
+ app-text/ptex
+ app-text/cstetex
+ app-text/dvipdfm ) )"
+
+DEPEND="${DEPEND}
+ dev-util/pkgconfig"
+
+PATCHES="${FILESDIR}/post-3.5.5-kdegraphics.diff
+ ${FILESDIR}/post-3.5.5-kdegraphics-CVE-2007-0104.diff"
+
+pkg_setup() {
+ kde_pkg_setup
+ for ghostscript in app-text/ghostscript-{gnu,esp,afpl}; do
+ if has_version ${ghostscript} && ! built_with_use ${ghostscript} X; then
+ eerror "This package requires ${ghostscript} compiled with X11 support."
+ eerror "Please reemerge ${ghostscript} with USE=\"X\"."
+ die "Please reemerge ${ghostscript} with USE=\"X\"."
+ fi
+ done
+ if use pdf && ! built_with_use app-text/poppler-bindings qt3; then
+ eerror "This package requires app-text/poppler-bindings compiled with Qt 3.x support."
+ eerror "Please reemerge app-text/poppler-bindings with USE=\"qt3\"."
+ die "Please reemerge app-text/poppler-bindings with USE=\"qt3\"."
+ fi
+}
+
+src_compile() {
+ local myconf="$(use_with openexr) $(use_with pdf poppler)
+ $(use_with gphoto2 kamera)"
+
+ use imlib || export DO_NOT_COMPILE="${DO_NOT_COMPILE} kuickshow"
+ use scanner || export DO_NOT_COMPILE="${DO_NOT_COMPILE} kooka libkscan"
+ use povray || export DO_NOT_COMPILE="${DO_NOT_COMPILE} kpovmodeler"
+ use pdf || export DO_NOT_COMPILE="${DO_NOT_COMPILE} kpdf"
+
+ rm -f ${S}/configure # ask rebuilding
+ kde_src_compile
+}