summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-server/crossfire-server/crossfire-server-1.6.0.ebuild')
-rw-r--r--games-server/crossfire-server/crossfire-server-1.6.0.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/games-server/crossfire-server/crossfire-server-1.6.0.ebuild b/games-server/crossfire-server/crossfire-server-1.6.0.ebuild
index aeb70675c762..c19e9562065f 100644
--- a/games-server/crossfire-server/crossfire-server-1.6.0.ebuild
+++ b/games-server/crossfire-server/crossfire-server-1.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-server/crossfire-server/crossfire-server-1.6.0.ebuild,v 1.2 2004/05/30 18:34:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-server/crossfire-server/crossfire-server-1.6.0.ebuild,v 1.3 2004/06/01 20:07:29 mr_bones_ Exp $
inherit eutils games
@@ -12,19 +12,22 @@ SRC_URI="mirror://sourceforge/crossfire/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ppc"
-IUSE=""
+IUSE="X"
-DEPEND="X? ( virtual/x11 media-libs/libpng )"
+DEPEND="virtual/glibc
+ X? (
+ virtual/x11
+ media-libs/libpng )"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
src_compile() {
- egamesconf `use_with X x` || die
+ egamesconf $(use_with X x) || die
emake || die "emake failed"
}
src_install() {
- make install DESTDIR=${D} || die
+ make install DESTDIR="${D}" || die "make install failed"
dodoc AUTHORS ChangeLog DEVELOPERS NEWS README TODO
prepgamesdirs
}