summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-misc/opengfx/opengfx-0.4.4.ebuild')
-rw-r--r--games-misc/opengfx/opengfx-0.4.4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/games-misc/opengfx/opengfx-0.4.4.ebuild b/games-misc/opengfx/opengfx-0.4.4.ebuild
new file mode 100644
index 000000000000..3882a5928bc4
--- /dev/null
+++ b/games-misc/opengfx/opengfx-0.4.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/opengfx/opengfx-0.4.4.ebuild,v 1.1 2012/04/17 12:35:45 scarabeus Exp $
+
+EAPI=3
+inherit games
+
+DESCRIPTION="OpenGFX data files for OpenTTD"
+HOMEPAGE="http://bundles.openttdcoop.org/opengfx/"
+SRC_URI="http://bundles.openttdcoop.org/opengfx/releases/${PV}/${P}-source.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+S=${WORKDIR}/${P}-source
+
+DEPEND="
+ >=games-util/grfcodec-5.1.1
+ >=games-util/nml-0.2.3
+"
+RDEPEND=""
+
+src_prepare() {
+ sed -i -e 's/\[a-z\]/[[:alpha:]]/' ./scripts/Makefile.in || die
+}
+
+src_compile() {
+ emake bundle || die
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}/openttd/data/"
+ doins *.grf opengfx.obg || die
+ dodoc docs/{changelog.txt,readme.txt}
+ prepgamesdirs
+}