summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/nwwine/nwwine-20030709.ebuild')
-rw-r--r--games-emulation/nwwine/nwwine-20030709.ebuild122
1 files changed, 0 insertions, 122 deletions
diff --git a/games-emulation/nwwine/nwwine-20030709.ebuild b/games-emulation/nwwine/nwwine-20030709.ebuild
deleted file mode 100644
index 69e31a62cc2b..000000000000
--- a/games-emulation/nwwine/nwwine-20030709.ebuild
+++ /dev/null
@@ -1,122 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/nwwine/nwwine-20030709.ebuild,v 1.6 2004/08/29 05:02:26 mr_bones_ Exp $
-
-DESCRIPTION="A special version of wine for the Neverwinter Nights toolkit"
-SRC_URI="mirror://gentoo/nwwine-20030618-misc.tar.bz2
- ftp://128.173.184.249/Linux/nwwine/nwwine-based-on-${PV}.tar.gz
- mirror://gentoo/nwwine-20030618-fake_windows.tar.bz2"
-
-HOMEPAGE="http://www.winehq.com/ http://republika.pl/nwnlinux/"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 -ppc -sparc"
-IUSE="X alsa arts cups nas opengl tcltk"
-S=${WORKDIR}/nwwine-based-on-${PV}
-
-DEPEND="sys-devel/gcc
- sys-devel/flex
- dev-util/yacc
- >=sys-apps/sed-4
- >=sys-libs/ncurses-5.2
- >=media-libs/freetype-2.0.0
- X? ( virtual/x11 )
- tcltk? ( dev-lang/tcl dev-lang/tk )
- arts? ( kde-base/arts )
- alsa? ( media-libs/alsa-lib )
- nas? ( media-libs/nas )
- cups? ( net-print/cups )
- opengl? ( virtual/opengl )"
-RDEPEND=""
-
-src_compile() {
- cd ${S}/dlls/opengl32
-
- cd ${S}
- #fix the nwwine wrapper
- mv nwwine.sh nwwine.old
- sed -e "s:wine:/usr/lib/nwwine/bin/wine:" nwwine.old > nwwine.sh
-
- local myconf
-
- use opengl && myconf="--enable-opengl" || myconf="--disable-opengl"
- [ -z $DEBUG ] && myconf="$myconf --disable-trace --disable-debug" || myconf="$myconf --enable-trace --enable-debug"
- # there's no configure flag for cups, arts, alsa and nas, it's supposed to be autodetected
-
- # use the default setting in ./configure over the /etc/make.conf setting
- unset CFLAGS CXXFLAGS
-
- ./configure --prefix=/usr/lib/${PN} \
- --sysconfdir=/etc/${PN} \
- --host=${CHOST} \
- --enable-curses \
- ${myconf} || die "configure failed"
-
- # No parallel make
- make depend all || die "make depend all failed"
- cd programs && emake || die
-}
-
-src_install () {
- local WINEMAKEOPTS="prefix=${D}/usr/lib/${PN}"
-
- ### Install wine to ${D}
- cd ${S}
- make ${WINEMAKEOPTS} install || die
- cd ${S}/programs
- make ${WINEMAKEOPTS} install || die
-
- # Needed for later installation
- dodir /usr/bin
-
- ### Creation of /usr/lib/${PN}/.data
- # set up fake_windows
- dodir /usr/lib/${PN}/.data
- cd ${D}/usr/lib/nwwine/.data
- cp -r ${WORKDIR}/fake_windows .
-
- # copy config
- cp ${WORKDIR}/config .
-
- # put winedefault.reg into .data
- cp ${S}/winedefault.reg .
-
- # move wrappers to bin/
- cd ${WORKDIR}
- insinto /usr/bin
- dobin regedit-nwwine nwwine
- rm regedit-nwwine nwwine
-
- # set up this dynamic data
- cd ${S}
- insinto /usr/lib/${PN}/.data/fake_windows/Windows
- doins documentation/samples/system.ini
- doins documentation/samples/generic.ppd
- ## Setup of .data complete
-
- ### Misc tasks
- # take care of the documentation
- cd ${S}
- dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS LICENSE README
-
- # manpage setup
- mv ${D}/usr/lib/${PN}/man/man1/wine.1 ${D}/usr/lib/${PN}/man/man1/${PN}.1
- doman ${D}/usr/lib/${PN}/man/man1/${PN}.1
- rm ${D}/usr/lib/${PN}/man/man1/${PN}.1
-
- # remove the executable flag from those libraries.
- cd ${D}/usr/lib/${PN}/lib/wine
- chmod a-x *.so
-}
-
-pkg_postinst() {
- einfo "Use /usr/bin/nwwine to start wine. This is a wrapper-script"
- einfo "which will take care of everything else."
- einfo ""
- einfo "Use /usr/bin/regedit-nwwine to import registry files into the"
- einfo "wine registry."
- einfo ""
- einfo "If you have bugs, enhancements or patches"
- einfo "report a bug and assign it to wine@gentoo.org"
-}