summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/gens/gens-2.15.4.ebuild')
-rw-r--r--games-emulation/gens/gens-2.15.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/games-emulation/gens/gens-2.15.4.ebuild b/games-emulation/gens/gens-2.15.4.ebuild
new file mode 100644
index 000000000000..dc7b40f257ee
--- /dev/null
+++ b/games-emulation/gens/gens-2.15.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gens/gens-2.15.4.ebuild,v 1.1 2008/09/10 22:00:55 mr_bones_ Exp $
+
+inherit eutils flag-o-matic games
+
+DESCRIPTION="A Sega Genesis/CD/32X emulator"
+HOMEPAGE="http://gens.consolemul.com/"
+SRC_URI="mirror://sourceforge/gens/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="virtual/opengl
+ >=media-libs/libsdl-1.2
+ >=x11-libs/gtk+-2.4"
+DEPEND="${RDEPEND}
+ >=dev-lang/nasm-0.98"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-romsdir.patch
+ append-ldflags -Wl,-z,noexecstack
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS BUGS README
+ prepgamesdirs
+}