summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/gnugo/gnugo-3.7.7.ebuild')
-rw-r--r--games-board/gnugo/gnugo-3.7.7.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/games-board/gnugo/gnugo-3.7.7.ebuild b/games-board/gnugo/gnugo-3.7.7.ebuild
new file mode 100644
index 000000000000..7f3a8b969afd
--- /dev/null
+++ b/games-board/gnugo/gnugo-3.7.7.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/gnugo/gnugo-3.7.7.ebuild,v 1.1 2005/10/22 01:37:59 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="A Go-playing program"
+HOMEPAGE="http://www.gnu.org/software/gnugo/devel.html"
+SRC_URI="ftp://sporadic.stanford.edu/pub/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=sys-libs/ncurses-5.2-r3
+ readline? ( sys-libs/readline )"
+
+src_compile() {
+ egamesconf \
+ $(use_with readline) \
+ --disable-dependency-tracking \
+ --enable-cache-size=32 || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+ prepgamesdirs
+}