summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/wop/wop-0.4.3-r1.ebuild')
-rw-r--r--games-arcade/wop/wop-0.4.3-r1.ebuild18
1 files changed, 8 insertions, 10 deletions
diff --git a/games-arcade/wop/wop-0.4.3-r1.ebuild b/games-arcade/wop/wop-0.4.3-r1.ebuild
index fe3a6a4301d3..2ab97a33e888 100644
--- a/games-arcade/wop/wop-0.4.3-r1.ebuild
+++ b/games-arcade/wop/wop-0.4.3-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/wop/wop-0.4.3-r1.ebuild,v 1.6 2009/01/27 14:42:16 tupone Exp $
-
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/wop/wop-0.4.3-r1.ebuild,v 1.7 2015/01/05 20:22:22 tupone Exp $
+EAPI=5
inherit eutils toolchain-funcs games
MY_DATA_V="2005-12-21"
@@ -26,9 +26,7 @@ DEPEND="${RDEPEND}
MY_DATA_S=${WORKDIR}/${MY_DATA_P}
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
# correct path to global woprc
sed -i \
-e "s:/etc/woprc:${GAMES_SYSCONFDIR}/woprc:g" \
@@ -44,15 +42,15 @@ src_unpack() {
}
src_compile() {
- emake CXX=$(tc-getCXX) || die "emake failed"
+ emake CXX=$(tc-getCXX)
}
src_install() {
- dogamesbin bin/${PN} || die "dogamesbin failed"
+ dogamesbin bin/${PN}
insinto "${GAMES_DATADIR}"/${PN}
- doins -r "${MY_DATA_S}"/* || die "doins data failed"
+ doins -r "${MY_DATA_S}"/*
insinto "${GAMES_SYSCONFDIR}"
- doins woprc || die "doins woprc failed"
+ doins woprc
newicon "${MY_DATA_S}"/images/misc/icons/wop16.png ${PN}.png
make_desktop_entry wop "Worms of Prey"
dodoc AUTHORS ChangeLog README{,-Libraries.txt} REVIEWS