summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/sdlsasteriods/sdlsasteriods-1.99-r1.ebuild')
-rw-r--r--games-arcade/sdlsasteriods/sdlsasteriods-1.99-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/games-arcade/sdlsasteriods/sdlsasteriods-1.99-r1.ebuild b/games-arcade/sdlsasteriods/sdlsasteriods-1.99-r1.ebuild
new file mode 100644
index 000000000000..4cf8b6dd1b3d
--- /dev/null
+++ b/games-arcade/sdlsasteriods/sdlsasteriods-1.99-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/sdlsasteriods/sdlsasteriods-1.99-r1.ebuild,v 1.1 2003/09/10 19:29:21 vapier Exp $
+
+inherit games
+
+MY_P="SDLSasteroids-${PV}"
+DESCRIPTION="Rework of Sasteroids using SDL"
+SRC_URI="mirror://sourceforge/sdlsas/${MY_P}.tar.gz"
+HOMEPAGE="http://sdlsas.sourceforge.net/"
+
+KEYWORDS="x86"
+LICENSE="GPL-2 freedist"
+SLOT="0"
+
+DEPEND=">=media-libs/sdl-mixer-1.2.0
+ media-libs/sdl-ttf"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ make GAMEDIR=${GAMES_DATADIR}/${PN} || die
+}
+
+src_install() {
+ dodir /usr/share/man/man6/
+ make \
+ GAMEDIR=${D}/${GAMES_DATADIR}/${PN} \
+ BINDIR=${D}/${GAMES_BINDIR} \
+ MANDIR=${D}/usr/share/man/ \
+ install || die
+ dodoc ChangeLog README README.xast
+ prepgamesdirs
+}