summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/bzflag/bzflag-2.0.12.ebuild')
-rw-r--r--games-action/bzflag/bzflag-2.0.12.ebuild10
1 files changed, 2 insertions, 8 deletions
diff --git a/games-action/bzflag/bzflag-2.0.12.ebuild b/games-action/bzflag/bzflag-2.0.12.ebuild
index 3a28bf948de3..68f678e9a458 100644
--- a/games-action/bzflag/bzflag-2.0.12.ebuild
+++ b/games-action/bzflag/bzflag-2.0.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/bzflag/bzflag-2.0.12.ebuild,v 1.8 2009/01/22 21:10:46 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/bzflag/bzflag-2.0.12.ebuild,v 1.9 2009/02/22 23:46:19 mr_bones_ Exp $
EAPI=2
inherit eutils flag-o-matic games
@@ -16,7 +16,7 @@ IUSE="dedicated sdl"
UIDEPEND="virtual/opengl
virtual/glu
- || ( media-libs/libsdl[joystick] <media-libs/libsdl-1.2.13-r1 )
+ media-libs/libsdl[joystick]
media-libs/glew
x11-libs/libICE
x11-libs/libSM
@@ -35,12 +35,6 @@ DEPEND=">=net-misc/curl-7.15.0
sdl? ( ${UIDEPEND} )
!sdl? ( !dedicated? ( ${UIDEPEND} ) )"
-pkg_setup() {
- # Only do the libsdl checks for !dedicated - bug #107792
- use dedicated || GAMES_USE_SDL="nojoystick"
- games_pkg_setup
-}
-
src_configure() {
local myconf