summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/cvs2svn/cvs2svn-2.1.1.ebuild')
-rw-r--r--dev-vcs/cvs2svn/cvs2svn-2.1.1.ebuild26
1 files changed, 21 insertions, 5 deletions
diff --git a/dev-vcs/cvs2svn/cvs2svn-2.1.1.ebuild b/dev-vcs/cvs2svn/cvs2svn-2.1.1.ebuild
index 7ce77b2ec142..9bdce604e05f 100644
--- a/dev-vcs/cvs2svn/cvs2svn-2.1.1.ebuild
+++ b/dev-vcs/cvs2svn/cvs2svn-2.1.1.ebuild
@@ -1,6 +1,11 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs2svn/cvs2svn-2.1.1.ebuild,v 1.2 2010/06/22 18:43:50 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs2svn/cvs2svn-2.1.1.ebuild,v 1.3 2011/03/25 21:25:47 arfrever Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
inherit distutils
@@ -15,11 +20,17 @@ SLOT="0"
KEYWORDS="alpha amd64 ia64 ppc x86"
IUSE=""
-DEPEND="dev-lang/python
- >=dev-vcs/subversion-1.0.9"
+DEPEND=">=dev-vcs/subversion-1.0.9"
RDEPEND="${DEPEND}
dev-vcs/rcs"
+PYTHON_MODNAME="cvs2svn_lib cvs2svn_rcsparse"
+
+src_prepare() {
+ distutils_src_prepare
+ python_convert_shebangs -r 2 .
+}
+
src_install() {
distutils_src_install
insinto "/usr/share/${PN}"
@@ -30,10 +41,15 @@ src_install() {
src_test() {
# Need this because subversion is localized, but the tests aren't
export LC_ALL=C
- python run-tests.py || die "tests failed"
+
+ testing() {
+ "$(PYTHON)" run-tests.py
+ }
+ python_execute_function testing
}
pkg_postinst() {
+ distutils_pkg_postinst
elog "Additional scripts and examples have been installed to:"
elog " /usr/share/${PN}/"
}