summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/pscan/Manifest2
-rw-r--r--dev-util/pscan/pscan-20000721.ebuild21
2 files changed, 14 insertions, 9 deletions
diff --git a/dev-util/pscan/Manifest b/dev-util/pscan/Manifest
index 6d606784a204..bb4b896166db 100644
--- a/dev-util/pscan/Manifest
+++ b/dev-util/pscan/Manifest
@@ -1,4 +1,4 @@
MD5 454fe81c671c36d73c11c66e7793bd81 ChangeLog 462
MD5 21cd68602737d7c996bceabf6e62c468 metadata.xml 223
-MD5 159b3af752b2ff874f8701588bc8f15e pscan-20000721.ebuild 778
+MD5 cbe840ce5a6827446668d9b75b111a76 pscan-20000721.ebuild 790
MD5 79eadb4eb3e61751b21c893cdd0a1708 files/digest-pscan-20000721 56
diff --git a/dev-util/pscan/pscan-20000721.ebuild b/dev-util/pscan/pscan-20000721.ebuild
index 1b2c553328f0..95a208c0ca9b 100644
--- a/dev-util/pscan/pscan-20000721.ebuild
+++ b/dev-util/pscan/pscan-20000721.ebuild
@@ -1,25 +1,30 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pscan/pscan-20000721.ebuild,v 1.2 2004/10/17 10:00:21 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pscan/pscan-20000721.ebuild,v 1.3 2004/10/26 13:53:46 vapier Exp $
-DESCRIPTION="PScan: A limited problem scanner for C source files"
+inherit toolchain-funcs
+
+DESCRIPTION="A limited problem scanner for C source files"
HOMEPAGE="http://www.striker.ottawa.on.ca/~aland/pscan/"
# I wish upstream would version their files, even if it's only with a date
SRC_URI="http://www.striker.ottawa.on.ca/~aland/pscan/pscan.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="~ppc ~x86"
IUSE=""
+
RDEPEND="virtual/libc"
-DEPEND="${RDEPEND} sys-devel/gcc sys-devel/flex"
+DEPEND="${RDEPEND}
+ sys-devel/flex"
+
S="${WORKDIR}/${PN}"
src_compile() {
- emake CC="gcc ${CFLAGS}"
+ emake CC="$(tc-getCC) ${CFLAGS}" || die
}
src_install() {
- into /usr
- dobin pscan
- dodoc COPYING README find_formats.sh test.c wu-ftpd.pscan
+ dobin pscan || die
+ dodoc README find_formats.sh test.c wu-ftpd.pscan
}