summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/eclipse-emf-bin/eclipse-emf-bin-2.0.2.ebuild')
-rw-r--r--dev-util/eclipse-emf-bin/eclipse-emf-bin-2.0.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/eclipse-emf-bin/eclipse-emf-bin-2.0.2.ebuild b/dev-util/eclipse-emf-bin/eclipse-emf-bin-2.0.2.ebuild
new file mode 100644
index 000000000000..c30bc8b994dd
--- /dev/null
+++ b/dev-util/eclipse-emf-bin/eclipse-emf-bin-2.0.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eclipse-emf-bin/eclipse-emf-bin-2.0.2.ebuild,v 1.1 2005/04/16 13:59:04 luckyduck Exp $
+
+inherit eclipse-ext
+
+DESCRIPTION="EMF is a modeling framework and code generation facility for building tools and other applications based on a structured data model."
+HOMEPAGE="http://www.eclipse.org/emf/"
+SRC_URI="http://download.eclipse.org/tools/emf/downloads/drops/2.0.1/R200409171617/emf-sdo-runtime-2.0.1.zip"
+LICENSE="CPL-1.0"
+SLOT="2"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=">=dev-util/eclipse-sdk-3.0.1
+ app-arch/unzip"
+
+src_unpack() {
+ mkdir ${S}
+ cd ${S}
+ unpack ${A}
+}
+
+src_compile() {
+ einfo "${P} is a binary package"
+}
+
+src_install () {
+ eclipse-ext_require-slot 3
+
+ eclipse-ext_create-ext-layout binary
+
+ eclipse-ext_install-features eclipse/features/*
+ eclipse-ext_install-plugins eclipse/plugins/*
+}