summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tcltk/tclcl/tclcl-1.16.ebuild')
-rw-r--r--dev-tcltk/tclcl/tclcl-1.16.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-tcltk/tclcl/tclcl-1.16.ebuild b/dev-tcltk/tclcl/tclcl-1.16.ebuild
deleted file mode 100644
index 7bdf5a364b28..000000000000
--- a/dev-tcltk/tclcl/tclcl-1.16.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclcl/tclcl-1.16.ebuild,v 1.3 2005/07/19 14:05:31 dholm Exp $
-
-inherit eutils
-
-MY_P="${PN}-src-${PV}"
-DESCRIPTION="Tcl/C++ interface library"
-HOMEPAGE="http://otcl-tclcl.sourceforge.net/tclcl/"
-SRC_URI="mirror://sourceforge/otcl-tclcl/${MY_P}.tar.gz"
-
-LICENSE="as-is"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE=""
-
-DEPEND=">=dev-lang/tcl-8.3.2
- >=dev-lang/tk-8.3.2
- >=dev-tcltk/otcl-1.0.8"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-http.patch
-}
-
-src_compile() {
- local tclv tkv myconf
-
- tclv=$(grep TCL_VER /usr/include/tcl.h | sed 's/^.*"\(.*\)".*/\1/')
- tkv=$(grep TK_VER /usr/include/tk.h | sed 's/^.*"\(.*\)".*/\1/')
- myconf="--with-tcl-ver=${tclv} --with-tk-ver=${tkv}"
-
- econf ${myconf} || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- dolib.a libtclcl.a
- dobin tcl2c++
- insinto /usr/include
- doins *.h
-
- dodoc FILES README VERSION
- dohtml CHANGES.html
-}