summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/vlad/vlad-2.2.5.ebuild')
-rw-r--r--dev-ruby/vlad/vlad-2.2.5.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/vlad/vlad-2.2.5.ebuild b/dev-ruby/vlad/vlad-2.2.5.ebuild
new file mode 100644
index 000000000000..40b1a3a95ed5
--- /dev/null
+++ b/dev-ruby/vlad/vlad-2.2.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/vlad/vlad-2.2.5.ebuild,v 1.1 2012/04/22 07:30:15 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="considerations.txt History.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Pragmatic application deployment automation, without mercy."
+HOMEPAGE="http://rubyhitsquad.com/Vlad_the_Deployer.html"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend ">=dev-ruby/hoe-2.9.2 test? ( dev-ruby/minitest )"
+ruby_add_rdepend ">=dev-ruby/rake-remote_task-2.0.0"
+
+all_ruby_prepare() {
+ # Keep Isolate from managing the dependencies.
+ sed -i -e '/isolate/ s:^:#:' Rakefile || die
+}