summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/protected_attributes/protected_attributes-1.0.5.ebuild')
-rw-r--r--dev-ruby/protected_attributes/protected_attributes-1.0.5.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/protected_attributes/protected_attributes-1.0.5.ebuild b/dev-ruby/protected_attributes/protected_attributes-1.0.5.ebuild
new file mode 100644
index 000000000000..7618aa03be78
--- /dev/null
+++ b/dev-ruby/protected_attributes/protected_attributes-1.0.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/protected_attributes/protected_attributes-1.0.5.ebuild,v 1.1 2014/02/13 08:10:27 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Protect attributes from mass-assignment in ActiveRecord models"
+HOMEPAGE="https://github.com/rails/protected_attributes"
+SRC_URI="https://github.com/rails/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SLOT="1"
+
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_rdepend "
+ =dev-ruby/activemodel-4*
+"
+
+ruby_add_bdepend "test? (
+ dev-ruby/bundler
+ =dev-ruby/actionpack-4*
+ =dev-ruby/activerecord-4*
+ dev-ruby/mocha
+ dev-ruby/sqlite3
+)"
+
+all_ruby_prepare() {
+ sed -i -e '/github/ s:^:#:' Gemfile || die
+}