summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/daemon_controller/daemon_controller-1.2.0-r1.ebuild')
-rw-r--r--dev-ruby/daemon_controller/daemon_controller-1.2.0-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/daemon_controller/daemon_controller-1.2.0-r1.ebuild b/dev-ruby/daemon_controller/daemon_controller-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..17b97d83bcfe
--- /dev/null
+++ b/dev-ruby/daemon_controller/daemon_controller-1.2.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/daemon_controller/daemon_controller-1.2.0-r1.ebuild,v 1.1 2014/12/29 07:35:26 graaff Exp $
+
+EAPI=5
+
+# jruby → fails tests, looks like Unix sockets are bad on JRuby
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A library for starting and stopping specific daemons programmatically in a robust manner"
+HOMEPAGE="http://github.com/FooBarWidget/daemon_controller"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # fix tests with RSpec 2
+ sed -i -e '1irequire "thread"' spec/test_helper.rb || die
+}