summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/activeresource/activeresource-3.2.15.ebuild')
-rw-r--r--dev-ruby/activeresource/activeresource-3.2.15.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-ruby/activeresource/activeresource-3.2.15.ebuild b/dev-ruby/activeresource/activeresource-3.2.15.ebuild
deleted file mode 100644
index bb5e5ba188b8..000000000000
--- a/dev-ruby/activeresource/activeresource-3.2.15.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/activeresource-3.2.15.ebuild,v 1.1 2013/10/17 06:35:02 graaff Exp $
-
-EAPI=5
-
-USE_RUBY="ruby18 ruby19"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activeresource.gemspec"
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="Think Active Record for web resources.."
-HOMEPAGE="http://rubyforge.org/projects/activeresource/"
-SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "~dev-ruby/activesupport-${PV}
- dev-ruby/builder:3"
-ruby_add_bdepend "
- test? (
- dev-ruby/test-unit:2
- >=dev-ruby/mocha-0.13.0:0.13
- )"
-
-all_ruby_prepare() {
- # Set test environment to our hand.
- rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
- sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
-
- # Make sure we use the test-unit gem since ruby18 does not provide
- # all the test-unit features needed.
- sed -i -e '1igem "test-unit"' test/abstract_unit.rb || die
-}