summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pylibacl/pylibacl-0.4.0.ebuild')
-rw-r--r--dev-python/pylibacl/pylibacl-0.4.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/pylibacl/pylibacl-0.4.0.ebuild b/dev-python/pylibacl/pylibacl-0.4.0.ebuild
new file mode 100644
index 000000000000..5931215aab28
--- /dev/null
+++ b/dev-python/pylibacl/pylibacl-0.4.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylibacl/pylibacl-0.4.0.ebuild,v 1.1 2008/09/01 21:50:02 hawking Exp $
+
+inherit distutils
+
+DESCRIPTION="Python interface to libacl"
+HOMEPAGE="http://sourceforge.net/projects/pylibacl/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND="virtual/python
+ sys-apps/acl"
+RDEPEND="${DEPEND}"
+
+src_test() {
+ PYTHONPATH="$(ls -d build/lib*)" python test/test_acls.py ||\
+ die "tests failed"
+}