summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/lockfile/lockfile-0.9.ebuild')
-rw-r--r--dev-python/lockfile/lockfile-0.9.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/lockfile/lockfile-0.9.ebuild b/dev-python/lockfile/lockfile-0.9.ebuild
deleted file mode 100644
index df8cfa7769c5..000000000000
--- a/dev-python/lockfile/lockfile-0.9.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/lockfile/lockfile-0.9.ebuild,v 1.3 2010/06/28 08:45:42 phajdan.jr Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2:2.5"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils
-
-DESCRIPTION="Platform-independent file locking module"
-HOMEPAGE="http://code.google.com/p/pylockfile/ http://pypi.python.org/pypi/lockfile http://smontanaro.dyndns.org/python/"
-SRC_URI="http://smontanaro.dyndns.org/python/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc"
-
-DEPEND="doc? ( dev-python/sphinx )"
-RDEPEND=""
-RESTRICT_PYTHON_ABIS="2.4 3.*"
-
-DOCS="ACKS README RELEASE-NOTES"
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- cd doc
- einfo "Generation of documentation"
- emake html || die "Generation of documentation failed"
- fi
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- cd doc/.build/html
- docinto html
- cp -R [a-z]* _static "${ED}usr/share/doc/${PF}/html" || die "Installation of documentation failed"
- fi
-}