summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ipython/ipython-0.8.4-r1.ebuild')
-rw-r--r--dev-python/ipython/ipython-0.8.4-r1.ebuild75
1 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/ipython/ipython-0.8.4-r1.ebuild b/dev-python/ipython/ipython-0.8.4-r1.ebuild
new file mode 100644
index 000000000000..95678929244f
--- /dev/null
+++ b/dev-python/ipython/ipython-0.8.4-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ipython/ipython-0.8.4-r1.ebuild,v 1.1 2008/07/06 08:41:03 bicatali Exp $
+
+NEED_PYTHON=2.3
+
+inherit eutils distutils elisp-common
+
+DESCRIPTION="An advanced interactive shell for Python."
+HOMEPAGE="http://ipython.scipy.org/"
+SRC_URI="http://ipython.scipy.org/dist/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~s390 ~x86"
+IUSE="doc examples emacs gnuplot"
+
+RDEPEND="gnuplot? ( dev-python/gnuplot-py )
+ emacs? ( app-emacs/python-mode virtual/emacs )
+ dev-python/pexpect"
+DEPEND="${RDEPEND}"
+
+PYTHON_MODNAME="IPython"
+SITEFILE="62ipython-gentoo.el"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-globalpath.patch
+ epatch "${FILESDIR}"/${P}-jobctrl.patch
+
+ sed -i \
+ -e '/examfiles)/d' \
+ -e '/manfiles)/d' \
+ -e '/manstatic)/d' \
+ -e 's/^docfiles.*/docfiles=""/' \
+ setup.py || die "sed failed"
+}
+
+src_compile() {
+ distutils_src_compile
+ if use emacs ; then
+ cd doc
+ elisp-comp ipython.el || die "elisp-comp failed"
+ fi
+}
+
+src_install() {
+ DOCS="doc/ChangeLog"
+ distutils_src_install
+
+ cd doc
+ insinto /usr/share/doc/${PF}
+
+ if use doc; then
+ doins -r *.pdf manual/* || die "doc install failed"
+ fi
+ if use examples ; then
+ doins -r examples || die "examples install failed"
+ fi
+ if use emacs ; then
+ elisp-install ${PN} ipython.el ipython.elc || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+ use emacs && elisp-site-regen
+}