summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/h5py/h5py-1.3.0.ebuild')
-rw-r--r--dev-python/h5py/h5py-1.3.0.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/dev-python/h5py/h5py-1.3.0.ebuild b/dev-python/h5py/h5py-1.3.0.ebuild
index 4ed50c67bb2b..ef680dead6e8 100644
--- a/dev-python/h5py/h5py-1.3.0.ebuild
+++ b/dev-python/h5py/h5py-1.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/h5py/h5py-1.3.0.ebuild,v 1.2 2010/07/23 20:51:56 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/h5py/h5py-1.3.0.ebuild,v 1.3 2010/07/23 21:11:23 arfrever Exp $
EAPI="3"
PYTHON_DEPEND="2"
@@ -8,7 +8,7 @@ SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="3.*"
DISTUTILS_SRC_TEST="setup.py"
-inherit distutils
+inherit distutils eutils
DESCRIPTION="A simple Python interface to HDF5 files."
HOMEPAGE="http://h5py.alfven.org/ http://code.google.com/p/h5py/ http://pypi.python.org/pypi/h5py"
@@ -26,3 +26,8 @@ RDEPEND="${DEPEND}"
PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-python-2.7.patch"
+ distutils_src_prepare
+}