summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/deform/deform-0.9.5.ebuild')
-rw-r--r--dev-python/deform/deform-0.9.5.ebuild22
1 files changed, 9 insertions, 13 deletions
diff --git a/dev-python/deform/deform-0.9.5.ebuild b/dev-python/deform/deform-0.9.5.ebuild
index db167b6ddef8..e581187bca01 100644
--- a/dev-python/deform/deform-0.9.5.ebuild
+++ b/dev-python/deform/deform-0.9.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/deform/deform-0.9.5.ebuild,v 1.1 2012/05/20 15:47:51 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/deform/deform-0.9.5.ebuild,v 1.2 2012/05/20 20:03:20 floppym Exp $
EAPI="3"
@@ -18,7 +18,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="repoze"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
+IUSE="test"
# Depend on peppercorn, translationstring and colander with Python 3 support
RDEPEND=">=dev-python/translationstring-1.1
@@ -26,23 +26,19 @@ RDEPEND=">=dev-python/translationstring-1.1
>=dev-python/peppercorn-0.4
>=dev-python/chameleon-1.2.3"
DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx )
test? ( dev-python/beautifulsoup:4 )"
# Include COPYRIGHT.txt because the license seems to require it.
DOCS="CHANGES.txt COPYRIGHT.txt README.txt"
-src_compile() {
- distutils_src_compile
- if use doc; then
- emake -C docs html
- fi
-}
-
src_install() {
distutils_src_install
- if use doc; then
- dohtml -r docs/_build/html/*
- fi
+ # Install only the .rst source, as sphinx processing requires
+ # a theme only available from git that contains hardcoded
+ # references to files on https://static.pylonsproject.org/ (so
+ # the docs would not actually work offline). Install the
+ # source, which is somewhat readable.
+ docinto docs
+ dodoc docs/*.rst || die
}