summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/MogileFS-Client-Async/MogileFS-Client-Async-0.030.0-r1.ebuild')
-rw-r--r--dev-perl/MogileFS-Client-Async/MogileFS-Client-Async-0.030.0-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-perl/MogileFS-Client-Async/MogileFS-Client-Async-0.030.0-r1.ebuild b/dev-perl/MogileFS-Client-Async/MogileFS-Client-Async-0.030.0-r1.ebuild
new file mode 100644
index 000000000000..d1deeb10916b
--- /dev/null
+++ b/dev-perl/MogileFS-Client-Async/MogileFS-Client-Async-0.030.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/MogileFS-Client-Async/MogileFS-Client-Async-0.030.0-r1.ebuild,v 1.1 2014/08/26 19:08:32 axs Exp $
+
+EAPI=5
+
+MODULE_AUTHOR=DLAMBLEY
+MODULE_VERSION=${PV%.0}
+inherit perl-module
+
+DESCRIPTION="MogileFS Client using AnyEvent non-blocking IO"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-perl/IO-AIO
+ dev-perl/AnyEvent
+ dev-perl/AnyEvent-HTTP
+ dev-perl/File-Slurp
+ >=dev-perl/MogileFS-Client-1.16
+ dev-perl/Try-Tiny
+ dev-perl/namespace-clean"
+DEPEND="${RDEPEND}"
+
+# Tests only available if you have a local mogilefsd on 127.0.0.1:7001
+#SRC_TEST="do"