summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/cl-prevalence/cl-prevalence-1-r1.ebuild7
-rw-r--r--dev-lisp/cl-prevalence/cl-prevalence-1.ebuild6
-rw-r--r--dev-lisp/cl-pxmlutils/cl-pxmlutils-0.0.9-r1.ebuild7
-rw-r--r--dev-lisp/cl-pxmlutils/cl-pxmlutils-0.0.9-r2.ebuild7
-rw-r--r--dev-lisp/cl-pxmlutils/cl-pxmlutils-0.0.9.ebuild7
-rw-r--r--dev-lisp/cl-regex/cl-regex-1-r1.ebuild12
-rw-r--r--dev-lisp/cl-regex/cl-regex-1.ebuild11
-rw-r--r--dev-lisp/cl-rsm-bool-comp/cl-rsm-bool-comp-1.0-r1.ebuild9
-rw-r--r--dev-lisp/cl-rsm-bool-comp/cl-rsm-bool-comp-1.0.ebuild10
-rw-r--r--dev-lisp/cl-rt/cl-rt-20030428a-r1.ebuild12
-rw-r--r--dev-lisp/cl-rt/cl-rt-20030428a.ebuild14
-rw-r--r--dev-lisp/cl-sdl/cl-sdl-0.2.1-r1.ebuild8
-rw-r--r--dev-lisp/cl-sha1/cl-sha1-1.0-r1.ebuild9
-rw-r--r--dev-lisp/cl-sha1/cl-sha1-1.0.ebuild11
-rw-r--r--dev-lisp/cl-split-sequence/cl-split-sequence-20011114.1-r1.ebuild11
-rw-r--r--dev-lisp/cl-split-sequence/cl-split-sequence-20011114.1.ebuild12
-rw-r--r--dev-lisp/cl-sql/cl-sql-1.7.6.ebuild10
-rw-r--r--dev-lisp/cl-sql/cl-sql-1.8.7.ebuild11
-rw-r--r--dev-lisp/cl-sql/cl-sql-1.8.8.ebuild10
-rw-r--r--dev-lisp/cl-statistics/cl-statistics-1.0.0.2-r1.ebuild11
-rw-r--r--dev-lisp/cl-statistics/cl-statistics-1.0.0.2.ebuild13
-rw-r--r--dev-lisp/cl-tclink/cl-tclink-3.3.1-r1.ebuild11
-rw-r--r--dev-lisp/cl-tclink/cl-tclink-3.3.1.ebuild13
-rw-r--r--dev-lisp/cl-uffi/cl-uffi-1.3.6.ebuild7
24 files changed, 123 insertions, 116 deletions
diff --git a/dev-lisp/cl-prevalence/cl-prevalence-1-r1.ebuild b/dev-lisp/cl-prevalence/cl-prevalence-1-r1.ebuild
index b1b375bdfd71..6d8ea2b862bb 100644
--- a/dev-lisp/cl-prevalence/cl-prevalence-1-r1.ebuild
+++ b/dev-lisp/cl-prevalence/cl-prevalence-1-r1.ebuild
@@ -1,15 +1,18 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-prevalence/cl-prevalence-1-r1.ebuild,v 1.1 2004/02/12 09:13:14 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-prevalence/cl-prevalence-1-r1.ebuild,v 1.2 2004/04/21 17:12:01 vapier Exp $
-inherit common-lisp
+inherit common-lisp eutils
DESCRIPTION="Common Lisp Prevalence is a proof of concept implementation of Object Prevalence"
HOMEPAGE="http://homepage.mac.com/svc/prevalence/readme.html"
SRC_URI="mirror://gentoo/prevalence-${PV}.tar.gz"
+
LICENSE="LLGPL-2.1"
SLOT="0"
KEYWORDS="~x86"
+IUSE=""
+
DEPEND="dev-lisp/cl-xml"
S=${WORKDIR}/prevalence
diff --git a/dev-lisp/cl-prevalence/cl-prevalence-1.ebuild b/dev-lisp/cl-prevalence/cl-prevalence-1.ebuild
index c20d3c7f5379..e493471e17de 100644
--- a/dev-lisp/cl-prevalence/cl-prevalence-1.ebuild
+++ b/dev-lisp/cl-prevalence/cl-prevalence-1.ebuild
@@ -1,16 +1,18 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-prevalence/cl-prevalence-1.ebuild,v 1.1 2004/01/10 05:58:51 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-prevalence/cl-prevalence-1.ebuild,v 1.2 2004/04/21 17:12:13 vapier Exp $
-inherit common-lisp
+inherit common-lisp eutils
DESCRIPTION="Common Lisp Prevalence is a proof of concept implementation of Object Prevalence"
HOMEPAGE="http://homepage.mac.com/svc/prevalence/readme.htm"
SRC_URI="mirror://gentoo/prevalence-${PV}.tar.gz"
+
LICENSE="LLGPL-2.1"
SLOT="0"
KEYWORDS="~x86"
IUSE=""
+
DEPEND="dev-lisp/cl-xml"
S=${WORKDIR}/prevalence
diff --git a/dev-lisp/cl-pxmlutils/cl-pxmlutils-0.0.9-r1.ebuild b/dev-lisp/cl-pxmlutils/cl-pxmlutils-0.0.9-r1.ebuild
index a6cdefb85ca2..c6696375a865 100644
--- a/dev-lisp/cl-pxmlutils/cl-pxmlutils-0.0.9-r1.ebuild
+++ b/dev-lisp/cl-pxmlutils/cl-pxmlutils-0.0.9-r1.ebuild
@@ -1,15 +1,18 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-pxmlutils/cl-pxmlutils-0.0.9-r1.ebuild,v 1.1 2004/02/12 09:13:15 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-pxmlutils/cl-pxmlutils-0.0.9-r1.ebuild,v 1.2 2004/04/21 17:12:27 vapier Exp $
-inherit common-lisp
+inherit common-lisp eutils
DESCRIPTION="Portable version of Franz's xmlutils."
HOMEPAGE="http://www.common-lisp.net/project/bese/pxmlutils.html"
SRC_URI="ftp://ftp.common-lisp.net/pub/project/bese/pxmlutils/pxmlutils_${PV}.tar.gz"
+
LICENSE="LLGPL-2.1"
SLOT="0"
KEYWORDS="~x86"
+IUSE=""
+
DEPEND="dev-lisp/common-lisp-controller
dev-lisp/cl-acl-compat
virtual/commonlisp"
diff --git a/dev-lisp/cl-pxmlutils/cl-pxmlutils-0.0.9-r2.ebuild b/dev-lisp/cl-pxmlutils/cl-pxmlutils-0.0.9-r2.ebuild
index b6ed590781d0..3fe5fb171d54 100644
--- a/dev-lisp/cl-pxmlutils/cl-pxmlutils-0.0.9-r2.ebuild
+++ b/dev-lisp/cl-pxmlutils/cl-pxmlutils-0.0.9-r2.ebuild
@@ -1,15 +1,18 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-pxmlutils/cl-pxmlutils-0.0.9-r2.ebuild,v 1.1 2004/03/31 08:06:27 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-pxmlutils/cl-pxmlutils-0.0.9-r2.ebuild,v 1.2 2004/04/21 17:12:40 vapier Exp $
-inherit common-lisp
+inherit common-lisp eutils
DESCRIPTION="Portable version of Franz's xmlutils. Includes XML and HTML parsers."
HOMEPAGE="http://www.common-lisp.net/project/bese/pxmlutils.html"
SRC_URI="ftp://ftp.common-lisp.net/pub/project/bese/pxmlutils/pxmlutils_${PV}.tar.gz"
+
LICENSE="LLGPL-2.1"
SLOT="0"
KEYWORDS="~x86"
+IUSE=""
+
DEPEND="dev-lisp/common-lisp-controller
dev-lisp/cl-acl-compat
virtual/commonlisp"
diff --git a/dev-lisp/cl-pxmlutils/cl-pxmlutils-0.0.9.ebuild b/dev-lisp/cl-pxmlutils/cl-pxmlutils-0.0.9.ebuild
index 4edf20dcd0c8..3f6a3c0fa460 100644
--- a/dev-lisp/cl-pxmlutils/cl-pxmlutils-0.0.9.ebuild
+++ b/dev-lisp/cl-pxmlutils/cl-pxmlutils-0.0.9.ebuild
@@ -1,15 +1,18 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-pxmlutils/cl-pxmlutils-0.0.9.ebuild,v 1.1 2004/01/28 04:59:11 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-pxmlutils/cl-pxmlutils-0.0.9.ebuild,v 1.2 2004/04/21 17:12:51 vapier Exp $
-inherit common-lisp
+inherit common-lisp eutils
DESCRIPTION="Portable version of Franz's xmlutils."
HOMEPAGE="http://www.common-lisp.net/project/bese/pxmlutils.html"
SRC_URI="ftp://ftp.common-lisp.net/pub/project/bese/pxmlutils/pxmlutils_${PV}.tar.gz"
+
LICENSE="LLGPL-2.1"
SLOT="0"
KEYWORDS="~x86"
+IUSE=""
+
DEPEND="dev-lisp/common-lisp-controller
dev-lisp/cl-acl-compat
virtual/commonlisp"
diff --git a/dev-lisp/cl-regex/cl-regex-1-r1.ebuild b/dev-lisp/cl-regex/cl-regex-1-r1.ebuild
index c735563649b3..f5af23893409 100644
--- a/dev-lisp/cl-regex/cl-regex-1-r1.ebuild
+++ b/dev-lisp/cl-regex/cl-regex-1-r1.ebuild
@@ -1,23 +1,23 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-regex/cl-regex-1-r1.ebuild,v 1.1 2004/02/12 09:13:19 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-regex/cl-regex-1-r1.ebuild,v 1.2 2004/04/21 17:13:15 vapier Exp $
-inherit common-lisp
+inherit common-lisp eutils
DESCRIPTION="Common Lisp regular expression compiler/matcher"
-HOMEPAGE="http://www.geocities.com/mparker762/clawk.html
- http://packages.debian.org/unstable/devel/cl-regex.html"
+HOMEPAGE="http://www.geocities.com/mparker762/clawk.html http://packages.debian.org/unstable/devel/cl-regex.html"
SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-regex/${PN}_${PV}.orig.tar.gz"
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="~x86"
+IUSE=""
+
DEPEND="dev-lisp/common-lisp-controller
virtual/commonlisp"
CLPACKAGE=regex
-S=${WORKDIR}/${P}
-
src_unpack() {
unpack ${A}
epatch ${FILESDIR}/${PV}-macs.lisp-gentoo.patch
diff --git a/dev-lisp/cl-regex/cl-regex-1.ebuild b/dev-lisp/cl-regex/cl-regex-1.ebuild
index 095f12b17874..7ee07c7fbe41 100644
--- a/dev-lisp/cl-regex/cl-regex-1.ebuild
+++ b/dev-lisp/cl-regex/cl-regex-1.ebuild
@@ -1,24 +1,23 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-regex/cl-regex-1.ebuild,v 1.3 2003/10/15 18:30:06 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-regex/cl-regex-1.ebuild,v 1.4 2004/04/21 17:13:42 vapier Exp $
-inherit common-lisp
+inherit common-lisp eutils
DESCRIPTION="Common Lisp regular expression compiler/matcher"
-HOMEPAGE="http://www.geocities.com/mparker762/clawk.html
- http://packages.debian.org/unstable/devel/cl-regex.html"
+HOMEPAGE="http://www.geocities.com/mparker762/clawk.html http://packages.debian.org/unstable/devel/cl-regex.html"
SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-regex/${PN}_${PV}.orig.tar.gz"
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="~x86"
IUSE=""
+
DEPEND="dev-lisp/common-lisp-controller
virtual/commonlisp"
CLPACKAGE=regex
-S=${WORKDIR}/${P}
-
src_unpack() {
unpack ${A}
epatch ${FILESDIR}/${PV}-macs.lisp-gentoo.patch
diff --git a/dev-lisp/cl-rsm-bool-comp/cl-rsm-bool-comp-1.0-r1.ebuild b/dev-lisp/cl-rsm-bool-comp/cl-rsm-bool-comp-1.0-r1.ebuild
index 81645ff9520f..d89e5bf53a11 100644
--- a/dev-lisp/cl-rsm-bool-comp/cl-rsm-bool-comp-1.0-r1.ebuild
+++ b/dev-lisp/cl-rsm-bool-comp/cl-rsm-bool-comp-1.0-r1.ebuild
@@ -1,23 +1,24 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-rsm-bool-comp/cl-rsm-bool-comp-1.0-r1.ebuild,v 1.1 2004/02/12 09:13:19 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-rsm-bool-comp/cl-rsm-bool-comp-1.0-r1.ebuild,v 1.2 2004/04/21 17:13:59 vapier Exp $
-inherit common-lisp
+inherit common-lisp eutils
DESCRIPTION="R. Scott McIntire's Common Lisp Boolean Function Comparison library."
HOMEPAGE="http://packages.debian.org/unstable/devel/cl-rsm-bool-comp.html"
SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-rsm-bool-comp/cl-rsm-bool-comp_${PV}.tar.gz"
+
LICENSE="BSD"
SLOT="0"
# Compilation problems on SBCL and runtime SEGV on CMUCL
KEYWORDS="-*"
+IUSE=""
+
DEPEND="dev-lisp/common-lisp-controller
virtual/commonlisp "
CLPACKAGE=rsm-bool-comp
-S=${WORKDIR}/${P}
-
src_unpack() {
unpack ${A}
epatch ${FILESDIR}/${P}-gentoo.patch.gz
diff --git a/dev-lisp/cl-rsm-bool-comp/cl-rsm-bool-comp-1.0.ebuild b/dev-lisp/cl-rsm-bool-comp/cl-rsm-bool-comp-1.0.ebuild
index 660d4ad16748..7142fa40f31f 100644
--- a/dev-lisp/cl-rsm-bool-comp/cl-rsm-bool-comp-1.0.ebuild
+++ b/dev-lisp/cl-rsm-bool-comp/cl-rsm-bool-comp-1.0.ebuild
@@ -1,24 +1,24 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-rsm-bool-comp/cl-rsm-bool-comp-1.0.ebuild,v 1.2 2003/10/27 00:12:53 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-rsm-bool-comp/cl-rsm-bool-comp-1.0.ebuild,v 1.3 2004/04/21 17:14:11 vapier Exp $
-inherit common-lisp
+inherit common-lisp eutils
DESCRIPTION="McIntire's Common Lisp Boolean Function Comparison Library"
HOMEPAGE="http://packages.debian.org/unstable/devel/cl-rsm-bool-comp.html"
SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-rsm-bool-comp/cl-rsm-bool-comp_1.0.tar.gz"
+
LICENSE="BSD"
SLOT="0"
# Compilation problems on SBCL and runtime SEGV on CMUCL
KEYWORDS="-x86"
IUSE=""
+
DEPEND="dev-lisp/common-lisp-controller
virtual/commonlisp "
CLPACKAGE=rsm-bool-comp
-S=${WORKDIR}/${P}
-
src_unpack() {
unpack ${A}
epatch ${FILESDIR}/${P}-gentoo.patch.gz
diff --git a/dev-lisp/cl-rt/cl-rt-20030428a-r1.ebuild b/dev-lisp/cl-rt/cl-rt-20030428a-r1.ebuild
index 55ac89c79268..13afe66517de 100644
--- a/dev-lisp/cl-rt/cl-rt-20030428a-r1.ebuild
+++ b/dev-lisp/cl-rt/cl-rt-20030428a-r1.ebuild
@@ -1,28 +1,26 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-rt/cl-rt-20030428a-r1.ebuild,v 1.1 2004/02/12 09:13:20 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-rt/cl-rt-20030428a-r1.ebuild,v 1.2 2004/04/21 17:14:39 vapier Exp $
-inherit common-lisp
+inherit common-lisp eutils
DEB_PV=1
DESCRIPTION="Common Lisp regression tester from MIT"
-HOMEPAGE="http://www-2.cs.cmu.edu/afs/cs/project/ai-repository/ai/lang/lisp/code/testing/rt/
- http://packages.debian.org/unstable/devel/cl-rt.html
- http://www.cliki.net/rt"
+HOMEPAGE="http://www-2.cs.cmu.edu/afs/cs/project/ai-repository/ai/lang/lisp/code/testing/rt/ http://packages.debian.org/unstable/devel/cl-rt.html http://www.cliki.net/rt"
SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-rt/${PN}_${PV}.orig.tar.gz
http://ftp.debian.org/debian/pool/main/c/cl-rt/cl-rt_${PV}-${DEB_PV}.diff.gz"
+
LICENSE="MIT"
SLOT="0"
KEYWORDS="~x86"
IUSE=""
+
DEPEND="dev-lisp/common-lisp-controller
virtual/commonlisp"
CLPACKAGE=rt
-S=${WORKDIR}/${P}
-
src_unpack() {
unpack ${A}
epatch cl-rt_${PV}-${DEB_PV}.diff
diff --git a/dev-lisp/cl-rt/cl-rt-20030428a.ebuild b/dev-lisp/cl-rt/cl-rt-20030428a.ebuild
index 4769c54326a3..7b5764609289 100644
--- a/dev-lisp/cl-rt/cl-rt-20030428a.ebuild
+++ b/dev-lisp/cl-rt/cl-rt-20030428a.ebuild
@@ -1,28 +1,26 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-rt/cl-rt-20030428a.ebuild,v 1.3 2003/10/17 04:35:02 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-rt/cl-rt-20030428a.ebuild,v 1.4 2004/04/21 17:15:45 vapier Exp $
-inherit common-lisp
+inherit common-lisp eutils
DEB_PV=1
DESCRIPTION="Common Lisp regression tester from MIT"
-HOMEPAGE="http://www-2.cs.cmu.edu/afs/cs/project/ai-repository/ai/lang/lisp/code/testing/rt/
- http://packages.debian.org/unstable/devel/cl-rt.html
- http://www.cliki.net/rt"
+HOMEPAGE="http://www-2.cs.cmu.edu/afs/cs/project/ai-repository/ai/lang/lisp/code/testing/rt/ http://packages.debian.org/unstable/devel/cl-rt.html http://www.cliki.net/rt"
SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-rt/${PN}_${PV}.orig.tar.gz
http://ftp.debian.org/debian/pool/main/c/cl-rt/cl-rt_${PV}-${DEB_PV}.diff.gz"
+
LICENSE="MIT"
SLOT="0"
KEYWORDS="~x86"
IUSE=""
+
DEPEND="dev-lisp/common-lisp-controller
virtual/commonlisp"
CLPACKAGE=rt
-S=${WORKDIR}/${P}
-
src_unpack() {
unpack ${A}
epatch cl-rt_${PV}-${DEB_PV}.diff
diff --git a/dev-lisp/cl-sdl/cl-sdl-0.2.1-r1.ebuild b/dev-lisp/cl-sdl/cl-sdl-0.2.1-r1.ebuild
index a3b19386fb8e..138a0f15371a 100644
--- a/dev-lisp/cl-sdl/cl-sdl-0.2.1-r1.ebuild
+++ b/dev-lisp/cl-sdl/cl-sdl-0.2.1-r1.ebuild
@@ -1,16 +1,18 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-sdl/cl-sdl-0.2.1-r1.ebuild,v 1.2 2003/10/17 18:21:29 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-sdl/cl-sdl-0.2.1-r1.ebuild,v 1.3 2004/04/21 17:17:20 vapier Exp $
-inherit common-lisp
+inherit common-lisp eutils
DESCRIPTION="Common Lisp bindings to the SDL graphics library, and OpenGL libraries"
HOMEPAGE="http://cl-sdl.sourceforge.net/"
SRC_URI="mirror://sourceforge/cl-sdl/${PN}_${PV}.tar.gz"
+
LICENSE="MIT"
SLOT="0"
KEYWORDS="~x86"
IUSE=""
+
DEPEND="dev-lisp/cl-uffi
=media-libs/libsdl-1.2*
=media-libs/sdl-ttf-2*
diff --git a/dev-lisp/cl-sha1/cl-sha1-1.0-r1.ebuild b/dev-lisp/cl-sha1/cl-sha1-1.0-r1.ebuild
index 88f325c2a752..a10d327a707b 100644
--- a/dev-lisp/cl-sha1/cl-sha1-1.0-r1.ebuild
+++ b/dev-lisp/cl-sha1/cl-sha1-1.0-r1.ebuild
@@ -1,17 +1,18 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-sha1/cl-sha1-1.0-r1.ebuild,v 1.1 2004/02/12 09:13:20 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-sha1/cl-sha1-1.0-r1.ebuild,v 1.2 2004/04/21 17:18:58 vapier Exp $
-inherit common-lisp
+inherit common-lisp eutils
DESCRIPTION="Common Lisp package for SHA1 Message Digests"
-HOMEPAGE="http://www.cs.rice.edu/~froydnj/lisp/
- http://www.cliki.net/sb-sha1"
+HOMEPAGE="http://www.cs.rice.edu/~froydnj/lisp/ http://www.cliki.net/sb-sha1"
SRC_URI="mirror://gentoo/sb-sha1-${PV}.tar.gz"
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="~x86"
IUSE=""
+
DEPEND="dev-lisp/common-lisp-controller
virtual/commonlisp"
diff --git a/dev-lisp/cl-sha1/cl-sha1-1.0.ebuild b/dev-lisp/cl-sha1/cl-sha1-1.0.ebuild
index 05a9671e85cd..2e3a613f6fa9 100644
--- a/dev-lisp/cl-sha1/cl-sha1-1.0.ebuild
+++ b/dev-lisp/cl-sha1/cl-sha1-1.0.ebuild
@@ -1,17 +1,18 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-sha1/cl-sha1-1.0.ebuild,v 1.2 2003/10/17 16:33:03 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-sha1/cl-sha1-1.0.ebuild,v 1.3 2004/04/21 17:22:01 vapier Exp $
-inherit common-lisp
+inherit common-lisp eutils
DESCRIPTION="Common Lisp package for SHA1 Message Digests"
-HOMEPAGE="http://www.cs.rice.edu/~froydnj/lisp/
- http://www.cliki.net/sb-sha1"
+HOMEPAGE="http://www.cs.rice.edu/~froydnj/lisp/ http://www.cliki.net/sb-sha1"
SRC_URI="mirror://gentoo/sb-sha1-${PV}.tar.gz"
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="~x86"
IUSE=""
+
DEPEND="dev-lisp/common-lisp-controller
virtual/commonlisp"
diff --git a/dev-lisp/cl-split-sequence/cl-split-sequence-20011114.1-r1.ebuild b/dev-lisp/cl-split-sequence/cl-split-sequence-20011114.1-r1.ebuild
index c51821d87158..c3c9b80a5859 100644
--- a/dev-lisp/cl-split-sequence/cl-split-sequence-20011114.1-r1.ebuild
+++ b/dev-lisp/cl-split-sequence/cl-split-sequence-20011114.1-r1.ebuild
@@ -1,21 +1,20 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-split-sequence/cl-split-sequence-20011114.1-r1.ebuild,v 1.1 2004/02/12 09:13:20 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-split-sequence/cl-split-sequence-20011114.1-r1.ebuild,v 1.2 2004/04/21 17:23:28 vapier Exp $
-inherit common-lisp
+inherit common-lisp eutils
DEB_PV=1
DESCRIPTION="Functions to partition a Common Lisp sequence into multiple result sequences"
-HOMEPAGE="http://www.cliki.net/SPLIT-SEQUENCE
- http://packages.debian.org/unstable/devel/cl-split-sequence.html"
+HOMEPAGE="http://www.cliki.net/SPLIT-SEQUENCE http://packages.debian.org/unstable/devel/cl-split-sequence.html"
SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-split-sequence/${PN}_${PV}.orig.tar.gz
http://ftp.debian.org/debian/pool/main/c/cl-split-sequence/${PN}_${PV}-${DEB_PV}.diff.gz"
+
LICENSE="public-domain"
SLOT="0"
KEYWORDS="~x86"
-
-S=${WORKDIR}/${P}
+IUSE=""
CLPACKAGE=split-sequence
diff --git a/dev-lisp/cl-split-sequence/cl-split-sequence-20011114.1.ebuild b/dev-lisp/cl-split-sequence/cl-split-sequence-20011114.1.ebuild
index 342f4fc7321d..adeeed4becfe 100644
--- a/dev-lisp/cl-split-sequence/cl-split-sequence-20011114.1.ebuild
+++ b/dev-lisp/cl-split-sequence/cl-split-sequence-20011114.1.ebuild
@@ -1,23 +1,21 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-split-sequence/cl-split-sequence-20011114.1.ebuild,v 1.2 2003/10/17 16:40:35 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-split-sequence/cl-split-sequence-20011114.1.ebuild,v 1.3 2004/04/21 17:23:42 vapier Exp $
-inherit common-lisp
+inherit common-lisp eutils
DEB_PV=1
DESCRIPTION="Functions to partition a Common Lisp sequence into multiple result sequences"
-HOMEPAGE="http://www.cliki.net/SPLIT-SEQUENCE
- http://packages.debian.org/unstable/devel/cl-split-sequence.html"
+HOMEPAGE="http://www.cliki.net/SPLIT-SEQUENCE http://packages.debian.org/unstable/devel/cl-split-sequence.html"
SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-split-sequence/${PN}_${PV}.orig.tar.gz
http://ftp.debian.org/debian/pool/main/c/cl-split-sequence/${PN}_${PV}-${DEB_PV}.diff.gz"
+
LICENSE="public-domain"
SLOT="0"
KEYWORDS="~x86"
IUSE=""
-S=${WORKDIR}/${P}
-
CLPACKAGE=split-sequence
src_unpack() {
diff --git a/dev-lisp/cl-sql/cl-sql-1.7.6.ebuild b/dev-lisp/cl-sql/cl-sql-1.7.6.ebuild
index 0495d81aa5c6..8d8bfc48bff9 100644
--- a/dev-lisp/cl-sql/cl-sql-1.7.6.ebuild
+++ b/dev-lisp/cl-sql/cl-sql-1.7.6.ebuild
@@ -1,21 +1,21 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-sql/cl-sql-1.7.6.ebuild,v 1.3 2004/04/21 16:47:06 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-sql/cl-sql-1.7.6.ebuild,v 1.4 2004/04/21 17:25:14 vapier Exp $
-inherit common-lisp
+inherit common-lisp eutils
DEB_PV=1
DESCRIPTION="A multi-platform SQL interface for Common Lisp"
-HOMEPAGE="http://clsql.med-info.com/
- http://packages.debian.org/unstable/devel/cl-sql.html
- http://www.cliki.net/CLSQL"
+HOMEPAGE="http://clsql.med-info.com/ http://packages.debian.org/unstable/devel/cl-sql.html http://www.cliki.net/CLSQL"
SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-sql/cl-sql_${PV}.orig.tar.gz
http://ftp.debian.org/debian/pool/main/c/cl-sql/cl-sql_${PV}-${DEB_PV}.diff.gz"
+
LICENSE="LLGPL-2.1"
SLOT="0"
KEYWORDS="~x86"
IUSE="postgres mysql"
+
DEPEND="dev-lisp/common-lisp-controller
virtual/commonlisp
dev-lisp/cl-uffi
diff --git a/dev-lisp/cl-sql/cl-sql-1.8.7.ebuild b/dev-lisp/cl-sql/cl-sql-1.8.7.ebuild
index 86a84f23189c..6423d3976f29 100644
--- a/dev-lisp/cl-sql/cl-sql-1.8.7.ebuild
+++ b/dev-lisp/cl-sql/cl-sql-1.8.7.ebuild
@@ -1,21 +1,21 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-sql/cl-sql-1.8.7.ebuild,v 1.1 2004/01/27 21:44:41 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-sql/cl-sql-1.8.7.ebuild,v 1.2 2004/04/21 17:26:15 vapier Exp $
-inherit common-lisp
+inherit common-lisp eutils
DEB_PV=1
DESCRIPTION="A multi-platform SQL interface for Common Lisp"
-HOMEPAGE="http://clsql.med-info.com/
- http://packages.debian.org/unstable/devel/cl-sql.html
- http://www.cliki.net/CLSQL"
+HOMEPAGE="http://clsql.med-info.com/ http://packages.debian.org/unstable/devel/cl-sql.html http://www.cliki.net/CLSQL"
SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-sql/cl-sql_${PV}.orig.tar.gz
http://ftp.debian.org/debian/pool/main/c/cl-sql/cl-sql_${PV}-${DEB_PV}.diff.gz"
+
LICENSE="LLGPL-2.1"
SLOT="0"
KEYWORDS="~x86"
IUSE="postgres mysql"
+
DEPEND="dev-lisp/common-lisp-controller
virtual/commonlisp
dev-lisp/cl-md5
@@ -116,7 +116,6 @@ pkg_prerm() {
use mysql && /usr/sbin/unregister-common-lisp-source clsql-mysql
}
-
pkg_preinst() {
rm -rf /usr/lib/common-lisp/*/clsql* || true
}
diff --git a/dev-lisp/cl-sql/cl-sql-1.8.8.ebuild b/dev-lisp/cl-sql/cl-sql-1.8.8.ebuild
index ab9a6a660bba..82b3e956e9ba 100644
--- a/dev-lisp/cl-sql/cl-sql-1.8.8.ebuild
+++ b/dev-lisp/cl-sql/cl-sql-1.8.8.ebuild
@@ -1,20 +1,20 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-sql/cl-sql-1.8.8.ebuild,v 1.1 2004/02/12 09:13:20 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-sql/cl-sql-1.8.8.ebuild,v 1.2 2004/04/21 17:26:33 vapier Exp $
-inherit common-lisp
+inherit common-lisp eutils
DEB_PV=1
DESCRIPTION="A multi-platform SQL interface for Common Lisp"
-HOMEPAGE="http://clsql.med-info.com/
- http://packages.debian.org/unstable/devel/cl-sql.html
- http://www.cliki.net/CLSQL"
+HOMEPAGE="http://clsql.med-info.com/ http://packages.debian.org/unstable/devel/cl-sql.html http://www.cliki.net/CLSQL"
SRC_URI="http://files.b9.com/clsql/clsql-${PV}.tar.gz"
+
LICENSE="LLGPL-2.1"
SLOT="0"
KEYWORDS="~x86"
IUSE="postgres mysql"
+
DEPEND="dev-lisp/common-lisp-controller
virtual/commonlisp
dev-lisp/cl-md5
diff --git a/dev-lisp/cl-statistics/cl-statistics-1.0.0.2-r1.ebuild b/dev-lisp/cl-statistics/cl-statistics-1.0.0.2-r1.ebuild
index a4b1d49c5ff7..b385eab17bd0 100644
--- a/dev-lisp/cl-statistics/cl-statistics-1.0.0.2-r1.ebuild
+++ b/dev-lisp/cl-statistics/cl-statistics-1.0.0.2-r1.ebuild
@@ -1,27 +1,26 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-statistics/cl-statistics-1.0.0.2-r1.ebuild,v 1.1 2004/02/12 09:13:20 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-statistics/cl-statistics-1.0.0.2-r1.ebuild,v 1.2 2004/04/21 17:26:47 vapier Exp $
-inherit common-lisp
+inherit common-lisp eutils
DEB_PV=1
DESCRIPTION="Common Lisp Statistics Package"
-HOMEPAGE="http://www.biolisp.org
- http://packages.debian.org/unstable/devel/cl-statistics.html"
+HOMEPAGE="http://www.biolisp.org http://packages.debian.org/unstable/devel/cl-statistics.html"
SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-statistics/${PN}_${PV}.orig.tar.gz
http://ftp.debian.org/debian/pool/main/c/cl-statistics/${PN}_${PV}-${DEB_PV}.diff.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
IUSE=""
+
DEPEND="dev-lisp/common-lisp-controller
virtual/commonlisp"
CLPACKAGE=cl-statistics
-S=${WORKDIR}/${P}
-
src_unpack() {
unpack ${A}
epatch ${PN}_${PV}-${DEB_PV}.diff
diff --git a/dev-lisp/cl-statistics/cl-statistics-1.0.0.2.ebuild b/dev-lisp/cl-statistics/cl-statistics-1.0.0.2.ebuild
index 9d815058b68b..5927570cb837 100644
--- a/dev-lisp/cl-statistics/cl-statistics-1.0.0.2.ebuild
+++ b/dev-lisp/cl-statistics/cl-statistics-1.0.0.2.ebuild
@@ -1,27 +1,26 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-statistics/cl-statistics-1.0.0.2.ebuild,v 1.1 2003/10/17 16:59:40 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-statistics/cl-statistics-1.0.0.2.ebuild,v 1.2 2004/04/21 17:27:06 vapier Exp $
-inherit common-lisp
+inherit common-lisp eutils
DEB_PV=1
DESCRIPTION="Common Lisp Statistics Package"
-HOMEPAGE="http://www.biolisp.org
- http://packages.debian.org/unstable/devel/cl-statistics.html"
+HOMEPAGE="http://www.biolisp.org http://packages.debian.org/unstable/devel/cl-statistics.html"
SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-statistics/${PN}_${PV}.orig.tar.gz
http://ftp.debian.org/debian/pool/main/c/cl-statistics/${PN}_${PV}-${DEB_PV}.diff.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
IUSE=""
+
DEPEND="dev-lisp/common-lisp-controller
virtual/commonlisp"
CLPACKAGE=cl-statistics
-S=${WORKDIR}/${P}
-
src_unpack() {
unpack ${A}
epatch ${PN}_${PV}-${DEB_PV}.diff
diff --git a/dev-lisp/cl-tclink/cl-tclink-3.3.1-r1.ebuild b/dev-lisp/cl-tclink/cl-tclink-3.3.1-r1.ebuild
index 5b90aa521b90..41e921aced9d 100644
--- a/dev-lisp/cl-tclink/cl-tclink-3.3.1-r1.ebuild
+++ b/dev-lisp/cl-tclink/cl-tclink-3.3.1-r1.ebuild
@@ -1,20 +1,21 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-tclink/cl-tclink-3.3.1-r1.ebuild,v 1.2 2004/03/24 17:09:44 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-tclink/cl-tclink-3.3.1-r1.ebuild,v 1.3 2004/04/21 17:27:30 vapier Exp $
-inherit common-lisp
+inherit common-lisp eutils
DEB_PV=3
DESCRIPTION="A library of Common Lisp bindings to the TrustCommerce transaction authorization system. Now you have no excuse for not doing Business with Common Lisp!"
-HOMEPAGE="http://www.cliki.net/CL-TCLink
- http://www.mapcar.org/~mrd/cl-tclink/"
+HOMEPAGE="http://www.cliki.net/CL-TCLink http://www.mapcar.org/~mrd/cl-tclink/"
SRC_URI="http://www.mapcar.org/~mrd/debs/unstable/source/${PN}_${PV}.orig.tar.gz
http://www.mapcar.org/~mrd/debs/unstable/source/${PN}_${PV}-${DEB_PV}.diff.gz"
+
LICENSE="LLGPL-2.1"
SLOT="0"
KEYWORDS="~x86"
IUSE="doc"
+
DEPEND="dev-lisp/common-lisp-controller
dev-libs/openssl
dev-lisp/cl-split-sequence
@@ -24,8 +25,6 @@ DEPEND="dev-lisp/common-lisp-controller
CLPACKAGE=tclink
-S=${WORKDIR}/${P}
-
src_unpack() {
unpack ${A}
epatch ${PN}_${PV}-${DEB_PV}.diff
diff --git a/dev-lisp/cl-tclink/cl-tclink-3.3.1.ebuild b/dev-lisp/cl-tclink/cl-tclink-3.3.1.ebuild
index 13c7ce8caedf..e668c61da6c9 100644
--- a/dev-lisp/cl-tclink/cl-tclink-3.3.1.ebuild
+++ b/dev-lisp/cl-tclink/cl-tclink-3.3.1.ebuild
@@ -1,20 +1,21 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-tclink/cl-tclink-3.3.1.ebuild,v 1.2 2004/03/24 17:09:44 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-tclink/cl-tclink-3.3.1.ebuild,v 1.3 2004/04/21 17:27:52 vapier Exp $
-inherit common-lisp
+inherit common-lisp eutils
DEB_PV=3
DESCRIPTION="A library of Common Lisp bindings to the TrustCommerce transaction authorization system. Now you have no excuse for not doing Business with Common Lisp!"
-HOMEPAGE="http://www.cliki.net/CL-TCLink
- http://www.mapcar.org/~mrd/cl-tclink/"
+HOMEPAGE="http://www.cliki.net/CL-TCLink http://www.mapcar.org/~mrd/cl-tclink/"
SRC_URI="http://www.mapcar.org/~mrd/debs/unstable/source/${PN}_${PV}.orig.tar.gz
http://www.mapcar.org/~mrd/debs/unstable/source/${PN}_${PV}-${DEB_PV}.diff.gz"
+
LICENSE="LLGPL-2.1"
SLOT="0"
KEYWORDS="~x86"
IUSE="doc"
+
DEPEND="dev-lisp/common-lisp-controller
dev-libs/openssl
dev-lisp/cl-split-sequence
@@ -24,8 +25,6 @@ DEPEND="dev-lisp/common-lisp-controller
CLPACKAGE=tclink
-S=${WORKDIR}/${P}
-
src_unpack() {
unpack ${A}
epatch ${PN}_${PV}-${DEB_PV}.diff
diff --git a/dev-lisp/cl-uffi/cl-uffi-1.3.6.ebuild b/dev-lisp/cl-uffi/cl-uffi-1.3.6.ebuild
index 7a2eb7d414e9..4be9dcaacd43 100644
--- a/dev-lisp/cl-uffi/cl-uffi-1.3.6.ebuild
+++ b/dev-lisp/cl-uffi/cl-uffi-1.3.6.ebuild
@@ -1,12 +1,13 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-uffi/cl-uffi-1.3.6.ebuild,v 1.2 2003/10/17 17:17:02 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-uffi/cl-uffi-1.3.6.ebuild,v 1.3 2004/04/21 17:28:06 vapier Exp $
-inherit common-lisp
+inherit common-lisp eutils
DESCRIPTION="UFFI is a package to [portably] interface Common Lisp programs with C-language compatible libraries."
HOMEPAGE="http://uffi.med-info.com/"
SRC_URI="http://files.b9.com/uffi/uffi-${PV}.tar.gz"
+
LICENSE="LLGPL-2.1"
SLOT="0"
KEYWORDS="~x86"