summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libxml2/libxml2-2.7.2-r2.ebuild')
-rw-r--r--dev-libs/libxml2/libxml2-2.7.2-r2.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-libs/libxml2/libxml2-2.7.2-r2.ebuild b/dev-libs/libxml2/libxml2-2.7.2-r2.ebuild
index d135459772ef..fb0c01643f1f 100644
--- a/dev-libs/libxml2/libxml2-2.7.2-r2.ebuild
+++ b/dev-libs/libxml2/libxml2-2.7.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.7.2-r2.ebuild,v 1.7 2009/01/26 00:34:45 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.7.2-r2.ebuild,v 1.8 2009/01/29 21:58:29 eva Exp $
inherit libtool flag-o-matic eutils python
@@ -112,6 +112,7 @@ src_install() {
pkg_postinst() {
if use python; then
python_version
+ python_need_rebuild
python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages
fi
@@ -136,5 +137,5 @@ pkg_postinst() {
}
pkg_postrm() {
- use python && python_mod_cleanup
+ python_mod_cleanup /usr/$(get_libdir)/python*/site-packages
}