summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libpcre/libpcre-6.3.ebuild')
-rw-r--r--dev-libs/libpcre/libpcre-6.3.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-libs/libpcre/libpcre-6.3.ebuild b/dev-libs/libpcre/libpcre-6.3.ebuild
new file mode 100644
index 000000000000..de47237b1c40
--- /dev/null
+++ b/dev-libs/libpcre/libpcre-6.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpcre/libpcre-6.3.ebuild,v 1.1 2005/08/22 20:37:24 eradicator Exp $
+
+inherit libtool flag-o-matic eutils
+
+DESCRIPTION="Perl-compatible regular expression library"
+HOMEPAGE="http://www.pcre.org/"
+SRC_URI="ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/pcre-${PV}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="3"
+KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~ppc-macos ~s390 ~sh sparc x86"
+IUSE="doc"
+
+DEPEND="dev-util/pkgconfig"
+
+S="${WORKDIR}/pcre-${PV}"
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+ epatch "${FILESDIR}"/pcre-6.3-uclibc-tuple.patch
+ use ppc-macos || epatch "${FILESDIR}"/pcre-6.3-link.patch
+
+ # TODO: Fix this. Use -fPIC just for the shared objects.
+ # position-independent code must used for all shared objects.
+ append-flags -fPIC
+ use ppc-macos || elibtoolize
+}
+
+src_compile() {
+ # How about the following flags?
+ # --enable-unicode-properties enable Unicode properties support
+ # --disable-stack-for-recursion disable use of stack recursion when matching
+ econf --enable-utf8 || die
+ emake all libpcrecpp.la || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ dodoc AUTHORS INSTALL NON-UNIX-USE
+ dodoc doc/*.txt doc/Tech.Notes
+ use doc && dohtml doc/html/*
+}