summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libhash/libhash-1.0.2.ebuild')
-rw-r--r--dev-libs/libhash/libhash-1.0.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/libhash/libhash-1.0.2.ebuild b/dev-libs/libhash/libhash-1.0.2.ebuild
new file mode 100644
index 000000000000..e0fa1ce9af7b
--- /dev/null
+++ b/dev-libs/libhash/libhash-1.0.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libhash/libhash-1.0.2.ebuild,v 1.1 2004/07/14 01:59:27 vapier Exp $
+
+inherit gcc
+
+DESCRIPTION="a small hash library written in C"
+HOMEPAGE="ftp://ftp.ugh.net.au/pub/unix/libhash/"
+SRC_URI="ftp://ftp.ugh.net.au/pub/unix/libhash/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="doc"
+
+DEPEND="virtual/libc"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ rm -f Makefile
+ $(gcc-getCC) ${CFLAGS} -fPIC -shared -o libhash.so hash.c || die ".so failed"
+ $(gcc-getCC) ${CFLAGS} -c -o libhash.a hash.c || die ".a failed"
+}
+
+src_install() {
+ insinto /usr/include
+ doins hash.h || die "hash.h"
+ dolib.so libhash.so || die "dolib.so"
+ dolib.a libhash.a || die "dolib.a"
+ doman *.3 || die "doman"
+ use doc && dodoc tests/*.c
+}