summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libebml/libebml-0.7.2.ebuild')
-rw-r--r--dev-libs/libebml/libebml-0.7.2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-libs/libebml/libebml-0.7.2.ebuild b/dev-libs/libebml/libebml-0.7.2.ebuild
new file mode 100644
index 000000000000..6f86d083434f
--- /dev/null
+++ b/dev-libs/libebml/libebml-0.7.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libebml/libebml-0.7.2.ebuild,v 1.1 2004/10/25 20:00:59 arj Exp $
+
+IUSE=""
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="Extensible binary format library (kinda like XML)"
+HOMEPAGE="http://www.matroska.org/"
+SRC_URI="http://www.bunkus.org/videotools/mkvtoolnix/sources/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/libebml-shared.patch
+}
+
+src_compile() {
+ cd ${S}/make/linux
+
+ # This fix is necessary due to libebml being used to generate
+ # shared libraries, such as the vlc plugin for mozilla. on archs
+ # that require shared objects to be compiled with -fPIC, this
+ # really shouldn't happen, but libebml doesn't produce an so.
+ # Travis Tilley <lv@gentoo.org>
+ append-flags -fPIC
+
+ sed -i -e 's/CXXFLAGS=/CXXFLAGS+=/g' Makefile
+ make PREFIX=/usr || die "make failed"
+}
+
+src_install() {
+ cd ${S}/make/linux
+ einstall libdir="${D}/usr/$(get_libdir)" || die "make install failed"
+ dodoc ${S}/LICENSE.*
+}