summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/xdoclet/xdoclet-1.2.0_beta1.ebuild')
-rw-r--r--dev-java/xdoclet/xdoclet-1.2.0_beta1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-java/xdoclet/xdoclet-1.2.0_beta1.ebuild b/dev-java/xdoclet/xdoclet-1.2.0_beta1.ebuild
new file mode 100644
index 000000000000..b8a9fbb3180f
--- /dev/null
+++ b/dev-java/xdoclet/xdoclet-1.2.0_beta1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/xdoclet/xdoclet-1.2.0_beta1.ebuild,v 1.1 2002/12/21 07:06:13 mkennedy Exp $
+
+DESCRIPTION="A code-generation engine primarily for EJB"
+HOMEPAGE="http://xdoclet.sf.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-src-${PV/_/-}.tgz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND=">=virtual/jdk-1.3"
+DEPEND="${RDEPEND}
+ dev-java/jikes
+ >=dev-java/ant-1.5"
+
+S=${WORKDIR}/
+
+src_unpack() {
+ unpack ${A}
+ einfo "Configuring build for Jikes"
+ cp build.properties build.properties~ \
+ && sed -e 's/compiler = modern/compiler = jikes/' <build.properties~ >build.properties
+}
+
+src_compile() {
+ ant || die
+}
+
+src_install() {
+ dojar target/lib/*.jar
+ dodoc LICENSE.txt
+ cp -r target/docs target/generated-xdocs samples ${D}/usr/share/doc/${P}
+}