summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/pgasync/pgasync-2.01.ebuild')
-rw-r--r--dev-db/pgasync/pgasync-2.01.ebuild18
1 files changed, 12 insertions, 6 deletions
diff --git a/dev-db/pgasync/pgasync-2.01.ebuild b/dev-db/pgasync/pgasync-2.01.ebuild
index 8de26ca1cb71..d6b322237be6 100644
--- a/dev-db/pgasync/pgasync-2.01.ebuild
+++ b/dev-db/pgasync/pgasync-2.01.ebuild
@@ -1,6 +1,11 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pgasync/pgasync-2.01.ebuild,v 1.2 2010/02/06 10:40:34 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgasync/pgasync-2.01.ebuild,v 1.3 2011/01/08 16:30:29 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
inherit distutils
@@ -13,15 +18,16 @@ SLOT="0"
KEYWORDS="~x86"
IUSE="doc"
-DEPEND=">=dev-python/twisted-1.3
- >=dev-lang/python-2.3"
+DEPEND=">=dev-python/twisted-1.3"
+RDEPEND="${DEPEND}"
-DOCS="CHANGELOG LICENSE PKG-INFO README TODO"
+DOCS="CHANGELOG PKG-INFO README TODO"
src_install() {
distutils_src_install
+
if use doc; then
insinto /usr/share/doc/${PF}
- doins -r examples
+ doins -r examples || die "doins failed"
fi
}