summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/libiodbc/libiodbc-3.51.1-r1.ebuild')
-rw-r--r--dev-db/libiodbc/libiodbc-3.51.1-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-db/libiodbc/libiodbc-3.51.1-r1.ebuild b/dev-db/libiodbc/libiodbc-3.51.1-r1.ebuild
new file mode 100644
index 000000000000..3e5cd11e6d8e
--- /dev/null
+++ b/dev-db/libiodbc/libiodbc-3.51.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libiodbc/libiodbc-3.51.1-r1.ebuild,v 1.1 2004/02/01 12:29:11 tantive Exp $
+S=${WORKDIR}/${P}
+DESCRIPTION="iODBC is the acronym for Independent Open DataBase Connectivity, an Open Source platform independent implementation of both the ODBC and X/Open specifications. It is rapidly emerging as the industry standard for developing solutions that are language, platform and database independent."
+SRC_URI="http://www.iodbc.org/dist/libiodbc-${PV}.tar.gz"
+HOMEPAGE="http://www.ioodbc.com"
+LICENSE="LGPL-2 BSD"
+DEPEND="gtk? ( =x11-libs/gtk+-1* )"
+IUSE="gtk"
+KEYWORDS="~x86"
+SLOT=0
+
+src_compile() {
+ local myconf
+ myconf="--prefix=${D}/usr/local --exec-prefix=${D}/usr/local --with-iodbc-inidir=/etc"
+ use gtk || myconf="$myconf --disable-gui --disable-gtktest"
+ econf ${myconf}
+ emake
+}
+
+src_install () {
+ make install || die "make install failed"
+ ## need to fix *.la
+ cd ${D}/usr/local/lib
+ for file in `ls *.la`; do
+ sed -i "s:"${D}"/usr/local:/usr/local:" $file;
+ done
+}