summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/sparsehash/sparsehash-1.10.ebuild')
-rw-r--r--dev-cpp/sparsehash/sparsehash-1.10.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/dev-cpp/sparsehash/sparsehash-1.10.ebuild b/dev-cpp/sparsehash/sparsehash-1.10.ebuild
index 49b176e7ee77..28aac64e6fdb 100644
--- a/dev-cpp/sparsehash/sparsehash-1.10.ebuild
+++ b/dev-cpp/sparsehash/sparsehash-1.10.ebuild
@@ -1,26 +1,28 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sparsehash/sparsehash-1.10.ebuild,v 1.1 2011/02/16 18:25:59 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sparsehash/sparsehash-1.10.ebuild,v 1.2 2011/04/28 13:33:14 jlec Exp $
-EAPI="3"
+EAPI="4"
-DESCRIPTION="An extremely memory-efficient hash_map implementation."
+inherit eutils
+
+DESCRIPTION="An extremely memory-efficient hash_map implementation"
HOMEPAGE="http://code.google.com/p/google-sparsehash/"
SRC_URI="http://google-sparsehash.googlecode.com/files/${P}.tar.gz"
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND=""
-RDEPEND=""
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-gcc46.patch
+}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ default
# Installs just every piece
rm -rf "${D}/usr/share/doc"
-
- dodoc AUTHORS ChangeLog NEWS README TODO
dohtml doc/*
}