summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/luabind/luabind-0.9.1.ebuild')
-rw-r--r--dev-cpp/luabind/luabind-0.9.1.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/dev-cpp/luabind/luabind-0.9.1.ebuild b/dev-cpp/luabind/luabind-0.9.1.ebuild
index 7a0453705f79..85be8e1369f0 100644
--- a/dev-cpp/luabind/luabind-0.9.1.ebuild
+++ b/dev-cpp/luabind/luabind-0.9.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/luabind/luabind-0.9.1.ebuild,v 1.1 2013/05/02 21:56:13 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/luabind/luabind-0.9.1.ebuild,v 1.2 2013/05/04 10:37:19 hasufell Exp $
# NOTE: cross compiling is probably broken
@@ -31,6 +31,7 @@ src_compile() {
bjam release \
-d+2 \
--prefix="${D}/usr/" \
+ --libdir="${D}/usr/$(get_libdir)" \
cflags="${CFLAGS}" \
linkflags="${LDFLAGS}" \
link=shared || die "compile failed"
@@ -40,13 +41,11 @@ src_install() {
bjam release \
-d+2 \
--prefix="${D}/usr/" \
+ --libdir="${D}/usr/$(get_libdir)" \
cflags="${CFLAGS}" \
linkflags="${LDFLAGS}" \
link=shared \
install || die "compile failed"
-
- # no idea how to fix that in Jamfile
- mv "${ED}"/usr/lib "${ED}"/usr/$(get_libdir)
}
# generally, this really sucks, patches welcome