summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/tree/tree-1.5.2.1.ebuild')
-rw-r--r--app-text/tree/tree-1.5.2.1.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/app-text/tree/tree-1.5.2.1.ebuild b/app-text/tree/tree-1.5.2.1.ebuild
index 5e976be70f66..b5ffd0ebc3d0 100644
--- a/app-text/tree/tree-1.5.2.1.ebuild
+++ b/app-text/tree/tree-1.5.2.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/tree/tree-1.5.2.1.ebuild,v 1.1 2008/09/16 19:51:15 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/tree/tree-1.5.2.1.ebuild,v 1.2 2008/11/18 01:25:52 vapier Exp $
-inherit toolchain-funcs bash-completion
+inherit toolchain-funcs flag-o-matic bash-completion
DESCRIPTION="Lists directories recursively, and produces an indented listing of files."
HOMEPAGE="http://mama.indstate.edu/users/ice/tree/"
@@ -13,10 +13,17 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE=""
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i 's:LINUX:__linux__:' tree.c
+}
+
src_compile() {
+ append-lfs-flags
emake \
CC="$(tc-getCC)" \
- CFLAGS="${CFLAGS} -DLINUX -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64" \
+ CFLAGS="${CFLAGS}" \
LDFLAGS="${LDFLAGS}" \
|| die "emake failed"
}