summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/glark/glark-1.7.7.ebuild')
-rw-r--r--app-text/glark/glark-1.7.7.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-text/glark/glark-1.7.7.ebuild b/app-text/glark/glark-1.7.7.ebuild
new file mode 100644
index 000000000000..e518d15f6426
--- /dev/null
+++ b/app-text/glark/glark-1.7.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/glark/glark-1.7.7.ebuild,v 1.1 2006/03/04 00:03:04 ciaranm Exp $
+
+inherit bash-completion
+
+DESCRIPTION="File searcher similar to grep but with fancy output"
+HOMEPAGE="http://www.incava.org/projects/glark/"
+SRC_URI="http://www.incava.org/pub/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~ppc-macos ~sparc ~x86"
+SLOT="0"
+LICENSE="LGPL-2.1"
+IUSE=""
+
+# perl dep is for pod2man
+DEPEND="virtual/ruby
+ dev-lang/perl"
+RDEPEND="virtual/ruby"
+
+src_compile() {
+ emake
+ # force the manpage to be rebuilt
+ rm ${PN}.1
+ make ${PN}.1
+}
+
+src_install () {
+ make DESTDIR="${D}" install
+ dobashcompletion "${FILESDIR}/1.7.4/glark-completion" ${PN}
+}
+