summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/djvu/files')
-rw-r--r--app-text/djvu/files/digest-djvu-3.5.173
-rw-r--r--app-text/djvu/files/djvu-3.5.16-gcc41-hash.patch180
-rw-r--r--app-text/djvu/files/djvu-3.5.16-gcc41.patch26
-rw-r--r--app-text/djvu/files/djvu-3.5.17-dont-prestrip-bins.patch36
-rw-r--r--app-text/djvu/files/gentoo-acdesktop.m462
5 files changed, 0 insertions, 307 deletions
diff --git a/app-text/djvu/files/digest-djvu-3.5.17 b/app-text/djvu/files/digest-djvu-3.5.17
deleted file mode 100644
index 3a03d05d9347..000000000000
--- a/app-text/djvu/files/digest-djvu-3.5.17
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 18e71eec1f7d59ef4710b405ea64650e djvulibre-3.5.17.tar.gz 2298690
-RMD160 1f9d2b1106d1e1898f04c0657b2c8b557246c33e djvulibre-3.5.17.tar.gz 2298690
-SHA256 a39977be3ca99f5b1d6a01a7795133c18de538bf20ff1f2d52d652bac94647c7 djvulibre-3.5.17.tar.gz 2298690
diff --git a/app-text/djvu/files/djvu-3.5.16-gcc41-hash.patch b/app-text/djvu/files/djvu-3.5.16-gcc41-hash.patch
deleted file mode 100644
index f11a8bdfec38..000000000000
--- a/app-text/djvu/files/djvu-3.5.16-gcc41-hash.patch
+++ /dev/null
@@ -1,180 +0,0 @@
---- libdjvu/GContainer.h.old 2006-01-29 11:04:51.000000000 +0100
-+++ libdjvu/GContainer.h 2006-01-29 11:05:32.000000000 +0100
-@@ -134,6 +134,88 @@
- //@{
-
-
-+// ------------------------------------------------------------
-+// HASH FUNCTIONS
-+// ------------------------------------------------------------
-+
-+
-+/** @name Hash functions
-+ These functions let you use template class \Ref{GMap} with the
-+ corresponding elementary types. The returned hash code may be reduced to
-+ an arbitrary range by computing its remainder modulo the upper bound of
-+ the range.
-+ @memo Hash functions for elementary types. */
-+//@{
-+
-+/** Hashing function (unsigned int). */
-+static inline unsigned int
-+hash(const unsigned int & x)
-+{
-+ return x;
-+}
-+
-+/** Hashing function (int). */
-+static inline unsigned int
-+hash(const int & x)
-+{
-+ return (unsigned int)x;
-+}
-+
-+/** Hashing function (long). */
-+static inline unsigned int
-+hash(const long & x)
-+{
-+ return (unsigned int)x;
-+}
-+
-+/** Hashing function (unsigned long). */
-+static inline unsigned int
-+hash(const unsigned long & x)
-+{
-+ return (unsigned int)x;
-+}
-+
-+/** Hashing function (void *). */
-+static inline unsigned int
-+hash(void * const & x)
-+{
-+ return (unsigned long) x;
-+}
-+
-+/** Hashing function (const void *). */
-+static inline unsigned int
-+hash(const void * const & x)
-+{
-+ return (unsigned long) x;
-+}
-+
-+/** Hashing function (float). */
-+static inline unsigned int
-+hash(const float & x)
-+{
-+ // optimizer will get rid of unnecessary code
-+ unsigned int *addr = (unsigned int*)&x;
-+ if (sizeof(float)<2*sizeof(unsigned int))
-+ return addr[0];
-+ else
-+ return addr[0]^addr[1];
-+}
-+
-+/** Hashing function (double). */
-+static inline unsigned int
-+hash(const double & x)
-+{
-+ // optimizer will get rid of unnecessary code
-+ unsigned int *addr = (unsigned int*)&x;
-+ if (sizeof(double)<2*sizeof(unsigned int))
-+ return addr[0];
-+ else if (sizeof(double)<4*sizeof(unsigned int))
-+ return addr[0]^addr[1];
-+ else
-+ return addr[0]^addr[1]^addr[2]^addr[3];
-+}
-+
-+
-
- // ------------------------------------------------------------
- // HELPER CLASSES
-@@ -1266,88 +1348,6 @@
- };
-
-
--// ------------------------------------------------------------
--// HASH FUNCTIONS
--// ------------------------------------------------------------
--
--
--/** @name Hash functions
-- These functions let you use template class \Ref{GMap} with the
-- corresponding elementary types. The returned hash code may be reduced to
-- an arbitrary range by computing its remainder modulo the upper bound of
-- the range.
-- @memo Hash functions for elementary types. */
--//@{
--
--/** Hashing function (unsigned int). */
--static inline unsigned int
--hash(const unsigned int & x)
--{
-- return x;
--}
--
--/** Hashing function (int). */
--static inline unsigned int
--hash(const int & x)
--{
-- return (unsigned int)x;
--}
--
--/** Hashing function (long). */
--static inline unsigned int
--hash(const long & x)
--{
-- return (unsigned int)x;
--}
--
--/** Hashing function (unsigned long). */
--static inline unsigned int
--hash(const unsigned long & x)
--{
-- return (unsigned int)x;
--}
--
--/** Hashing function (void *). */
--static inline unsigned int
--hash(void * const & x)
--{
-- return (unsigned long) x;
--}
--
--/** Hashing function (const void *). */
--static inline unsigned int
--hash(const void * const & x)
--{
-- return (unsigned long) x;
--}
--
--/** Hashing function (float). */
--static inline unsigned int
--hash(const float & x)
--{
-- // optimizer will get rid of unnecessary code
-- unsigned int *addr = (unsigned int*)&x;
-- if (sizeof(float)<2*sizeof(unsigned int))
-- return addr[0];
-- else
-- return addr[0]^addr[1];
--}
--
--/** Hashing function (double). */
--static inline unsigned int
--hash(const double & x)
--{
-- // optimizer will get rid of unnecessary code
-- unsigned int *addr = (unsigned int*)&x;
-- if (sizeof(double)<2*sizeof(unsigned int))
-- return addr[0];
-- else if (sizeof(double)<4*sizeof(unsigned int))
-- return addr[0]^addr[1];
-- else
-- return addr[0]^addr[1]^addr[2]^addr[3];
--}
--
--
- //@}
- //@}
- //@}
diff --git a/app-text/djvu/files/djvu-3.5.16-gcc41.patch b/app-text/djvu/files/djvu-3.5.16-gcc41.patch
deleted file mode 100644
index 922acf2be5c3..000000000000
--- a/app-text/djvu/files/djvu-3.5.16-gcc41.patch
+++ /dev/null
@@ -1,26 +0,0 @@
---- libdjvu/GURL.h.old 2006-01-29 10:22:53.000000000 +0100
-+++ libdjvu/GURL.h 2006-01-29 10:24:04.000000000 +0100
-@@ -278,10 +278,10 @@
- //@}
-
- /// Returns TRUE if #gurl1# and #gurl2# are the same
-- bool GURL::operator==(const GURL & gurl2) const;
-+ bool operator==(const GURL & gurl2) const;
-
- /// Returns TRUE if #gurl1# and #gurl2# are different
-- bool GURL::operator!=(const GURL & gurl2) const;
-+ bool operator!=(const GURL & gurl2) const;
-
- /// Assignment operator
- GURL & operator=(const GURL & url);
---- libdjvu/ByteStream.h.old 2006-01-29 10:24:38.000000000 +0100
-+++ libdjvu/ByteStream.h 2006-01-29 10:24:55.000000000 +0100
-@@ -242,7 +242,7 @@
- and writes it to the specified stream. */
- void formatmessage( const char *fmt, ... );
- /** Looks up the message and writes it to the specified stream. */
-- void ByteStream::writemessage( const char *message );
-+ void writemessage( const char *message );
- /** Writes a one-byte integer to a ByteStream. */
- void write8 (unsigned int card8);
- /** Writes a two-bytes integer to a ByteStream.
diff --git a/app-text/djvu/files/djvu-3.5.17-dont-prestrip-bins.patch b/app-text/djvu/files/djvu-3.5.17-dont-prestrip-bins.patch
deleted file mode 100644
index 87ebf9c1e197..000000000000
--- a/app-text/djvu/files/djvu-3.5.17-dont-prestrip-bins.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-diff -urN djvulibre-3.5.17.orig/gui/djview/Makefile.in djvulibre-3.5.17/gui/djview/Makefile.in
---- djvulibre-3.5.17.orig/gui/djview/Makefile.in 2004-08-24 19:58:55.000000000 +0200
-+++ djvulibre-3.5.17/gui/djview/Makefile.in 2006-06-02 09:11:29.000000000 +0200
-@@ -174,7 +174,7 @@
- install-bin: ${PROGRAM} FORCE
- ${INSTALL} -d ${DESTDIR}${bindir}
- ${LIBTOOL} --mode=install \
-- ${INSTALL_PROGRAM} -s ${PROGRAM} ${DESTDIR}${bindir}
-+ ${INSTALL_PROGRAM} ${PROGRAM} ${DESTDIR}${bindir}
-
- install-man: FORCE
- ${INSTALL} -d ${DESTDIR}${mandir}/man1
-diff -urN djvulibre-3.5.17.orig/tools/Makefile.in djvulibre-3.5.17/tools/Makefile.in
---- djvulibre-3.5.17.orig/tools/Makefile.in 2005-08-23 18:49:23.000000000 +0200
-+++ djvulibre-3.5.17/tools/Makefile.in 2006-06-02 09:10:52.000000000 +0200
-@@ -75,7 +75,7 @@
- ${INSTALL} -d ${DESTDIR}${bindir}
- for n in ${PROGRAMS} ; do \
- ${LIBTOOL} --mode=install \
-- ${INSTALL_PROGRAM} -s $$n ${DESTDIR}${bindir} \
-+ ${INSTALL_PROGRAM} $$n ${DESTDIR}${bindir} \
- || exit ; done
-
- install-scripts: FORCE
-diff -urN djvulibre-3.5.17.orig/xmltools/Makefile.in djvulibre-3.5.17/xmltools/Makefile.in
---- djvulibre-3.5.17.orig/xmltools/Makefile.in 2004-08-24 19:58:56.000000000 +0200
-+++ djvulibre-3.5.17/xmltools/Makefile.in 2006-06-02 09:10:30.000000000 +0200
-@@ -63,7 +63,7 @@
- ${INSTALL} -d ${DESTDIR}${bindir}
- for n in ${PROGRAMS} ; do \
- ${LIBTOOL} --mode=install \
-- ${INSTALL_PROGRAM} -s $$n ${DESTDIR}${bindir} \
-+ ${INSTALL_PROGRAM} $$n ${DESTDIR}${bindir} \
- || exit ; done
-
- install-data: FORCE
diff --git a/app-text/djvu/files/gentoo-acdesktop.m4 b/app-text/djvu/files/gentoo-acdesktop.m4
deleted file mode 100644
index 61e59245d483..000000000000
--- a/app-text/djvu/files/gentoo-acdesktop.m4
+++ /dev/null
@@ -1,62 +0,0 @@
-dnl Copyright (c) 2002 Leon Bottou and Yann Le Cun.
-dnl Copyright (c) 2001 AT&T
-dnl
-dnl Most of these macros are derived from macros listed
-dnl at the GNU Autoconf Macro Archive
-dnl http://www.gnu.org/software/ac-archive/
-dnl
-dnl This program is free software; you can redistribute it and/or modify
-dnl it under the terms of the GNU General Public License as published by
-dnl the Free Software Foundation; either version 2 of the License, or
-dnl (at your option) any later version.
-dnl
-dnl This program is distributed in the hope that it will be useful,
-dnl but WITHOUT ANY WARRANTY; without even the implied warranty of
-dnl MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-dnl GNU General Public License for more details.
-dnl
-dnl You should have received a copy of the GNU General Public License
-dnl along with this program; if not, write to the Free Software
-dnl Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA02111 USA
-dnl
-
-dnl -------------------------------------------------------
-dnl @synopsis AC_VARIFY(varname)
-dnl Replace expansion of $libdir, $datadir, $bindir, $prefix
-dnl by references to the variable.
-dnl -------------------------------------------------------
-AC_DEFUN([AC_VARIFY],[
- xdir="`eval echo \"$libdir\"`"
- $1=`echo [$]$1 | sed -e 's:^'"$xdir"'/:${libdir}/:'`
- xdir="`eval echo \"$datadir\"`"
- $1=`echo [$]$1 | sed -e 's:^'"$xdir"'/:${datadir}/:'`
- xdir="`eval echo \"$bindir\"`"
- $1=`echo [$]$1 | sed -e 's:^'"$xdir"'/:${bindir}/:'`
- xdir="`eval echo \"$prefix\"`"
- $1=`echo [$]$1 | sed -e 's:^'"$xdir"'/:${prefix}/:'`
-])
-
-
-dnl -------------------------------------------------------
-dnl @synopsis AC_LOCATE_DESKTOP_DIRS
-dnl Define installation paths for desktop config files
-dnl (mime types, menu entries, icons, etc.)
-dnl -------------------------------------------------------
-AC_DEFUN([AC_FIND_DESKTOP_DIRS],[
- dtop_applications=/usr/share/applications # XDG menu entries
- dtop_icons=/usr/share/icons # KDE-style icon directories
- dtop_mime_info=/usr/share/mime-info # Gnome mime database
- dtop_application_registry=/usr/share/application-registry # Gnome mime associations
- dtop_mimelnk=${kde_mimelnk} # KDE mime database
-
- AC_SUBST(dtop_applications)
- AC_SUBST(dtop_icons)
- AC_SUBST(dtop_pixmaps)
- AC_SUBST(dtop_mime_info)
- AC_SUBST(dtop_application_registry)
- AC_SUBST(dtop_applnk)
- AC_SUBST(dtop_mimelnk)
- AC_SUBST(dtop_menu)
-])
-
-