summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-pda/synce-libsynce/synce-libsynce-0.12.ebuild')
-rw-r--r--app-pda/synce-libsynce/synce-libsynce-0.12.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-pda/synce-libsynce/synce-libsynce-0.12.ebuild b/app-pda/synce-libsynce/synce-libsynce-0.12.ebuild
new file mode 100644
index 000000000000..022198cc319e
--- /dev/null
+++ b/app-pda/synce-libsynce/synce-libsynce-0.12.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-libsynce/synce-libsynce-0.12.ebuild,v 1.1 2008/11/13 16:24:58 mescalinum Exp $
+
+DESCRIPTION="SynCE - common library"
+HOMEPAGE="http://sourceforge.net/projects/synce/"
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="hal"
+DEPEND=">=dev-libs/check-0.8.3.1"
+
+SRC_URI="mirror://sourceforge/synce/libsynce-${PV}.tar.gz"
+S="${WORKDIR}/libsynce-${PV}"
+
+src_compile() {
+ econf $(use_enable hal hal-support) || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc README TODO ChangeLog
+}